tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Bobak <gpbo...@yahoo.com>
Subject Re: mod_jk with httpd & tomcat
Date Mon, 23 Jan 2006 18:57:45 GMT
I am using Tomcat 5.0.28 BTW.

G.

Greg Bobak <gpbobak@yahoo.com> wrote:  I am trying to get mod_jk to work with apache
2.0.55 and get this error on the load module:

Syntax error on line 276 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/mod_jk.so into server: ld.so.1: /usr/local/apache2/bin/httpd:
fatal: relocation error: file /usr/local/apache2/modules/mod_jk.so: symbol ap_null_cleanup:
referenced symbol not found


I have looked everywhere, and have been advised to recompile apache, which I have done successfully
a few times.  This is how I have recompiled:

./configure --prefix=/usr/local/apache2 --enable-mods-shared=all --enable-ssl=shared --enable-ssl
--with-ssl=/usr/local/ssl --enable-proxy --enable-proxy-connect --enable-proxy-ftp --enable-proxy-http
--enable-so --enable-rule="SHARED_CORE"

make
 
make install

I use "make clean" between attempts..Ihave tried withou the "SHARED_CORE" and without the
--enable-so because --enable-mods-shared=all should cover that.  Still no luck.

I am using Solaris 9.  Here is some diag info:

root@anf-echttp1:/usr/local/apache2/bin # ldd -d  /usr/local/apache2/modules/mod_jk.so
        libc.so.1 =>     /usr/lib/libc.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        symbol not found: ap_server_root                (/usr/local/apache2/modules/mod_jk.so)
        symbol not found: ap_null_cleanup               (/usr/local/apache2/modules/mod_jk.so)
        symbol not found: dir_module            (/usr/local/apache2/modules/mod_jk.so)
        /usr/platform/SUNW,Serverblade1/lib/libc_psr.so.1

root@anf-echttp1:/usr/local/apache2/bin # httpd -V
Server version: Apache/2.0.55
Server built:   Jan 23 2006 13:17:34
Server's Module Magic Number: 20020903:11
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_FCNTL_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

root@anf-echttp1:/usr/local/apache2/bin # httpd -v
Server version: Apache/2.0.55
Server built:   Jan 23 2006 13:17:34


Please advise as to what info would be helpful in determining the root cause.

Thanks for your help,
Greg





  
---------------------------------
 
 What are the most popular cars?  Find out at Yahoo! Autos


		
---------------------------------
 
 What are the most popular cars?  Find out at Yahoo! Autos
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message