tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akoulov, Alexandre [IT]" <alexandre.akou...@citigroup.com>
Subject Tomcat 5.5.x and java 1.4.x
Date Mon, 09 Jan 2006 04:27:49 GMT
Hi all,

Some time ago I built Tomcat 5.5.12 from source with java 1.5.0_05 and then ran it with the
same java version (ie 1.5.0_05). However, our requirements have changed since then and now
I need to run Tomcat 5.5.12 in java 1.4.2_10.

I've dropped the content of the 'compat' directory into the Tomcat5.5.12 installation directory
(as per instructions found on http://tomcat.apache.org/tomcat-5.5-doc/building.html and also
in RUNNING.txt). Then tried to start tomcat and got java.lang.UnsupportedClassVersionError,
which in our case indicates that classes that were compiled with the lower java version attempt
to run in the higher java version. This is exactly what I expected.

However, when doing the same thing with the Tomcat 5.5.12 binaries downloaded directly from
the tomcat.apache.org I was surprised to find that it started successfully. 

My question is: was Tomcat 5.5.12 binary version that can be downloaded from http://tomcat.apache.org/download-55.cgi#5.5.12
compiled with java 1.4?


Thanks a lot for your help on this issue.

Alex.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message