tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Question concerning java.lang.NoClassDefFoundError: javax/servlet/ServletContext
Date Wed, 07 Dec 2005 03:34:32 GMT
> From: John Poley [mailto:john@jpoley.com] 
> Subject: Re: Question concerning 
> java.lang.NoClassDefFoundError: javax/servlet/ServletContext
> 
> I even went so far as to start with a machine with 
> no development tools on it, downloading just the 
> elements I required, and then trying to redeploy.

Those elements would be?

The problem still looks like excess ServletContext classes being around.
Since you're getting NoClassDefFoundError rather than
ClassNotFoundException, there is a ServletContext already loaded from
somewhere.  If you happen to have j2ee.jar around, try getting rid of
it.

Have you looked at:
http://tomcat.apache.org/tomcat-5.5-doc/class-loader-howto.html
and compared that with what you're doing?

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message