tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Constabaris <ad...@unc.edu>
Subject Re: Apache Portable Runtime not found on the java.library.path
Date Tue, 20 Dec 2005 16:23:11 GMT
William Claxton wrote:
> Running Java JDK 1.4.  After upgrading to Tomcat 5.5 I get this error.  
> I have also installed the compatability upgrade for the Java Runtime.
> 
> "The Apache Portable Runtime which allows optimal performance in 
> production environments was not found on the java.library.path."
> 
> Any suggestion on how to resolve this?

add the following to CATALINA_OPTS:

-Djava.library.path=/path/to/lib

The path you should use is the directory that actually contains 
libtcnative-1.so

This is only documented in the BUILDING file in jni/native in the 
tomcat-native directory tree.

HTH

AC

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message