tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <remy.mauche...@gmail.com>
Subject Re: Tomcat 5.5.12 and SSL - https doesn't work
Date Wed, 02 Nov 2005 11:44:48 GMT
On 11/2/05, Stanislav Mironov <smironov@gmail.com> wrote:
> Hello All!
>
> I have upgraded Tomcat to 5.5.12 from 5.5.9.
> Now link https://host:8443 hangs forever trying to get response and
> http://host:8443 returns correct plain html page without SSL. So SSL
> actually doesn't work at all.
>
> My server.xml related to SSL is:
>     <!-- Define a SSL HTTP/1.1 Connector on port 8443 -->
>     <Connector port="8443" maxHttpHeaderSize="8192"
>                maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
>                enableLookups="false" disableUploadTimeout="true"
>                acceptCount="100" scheme="https" secure="true"
>                clientAuth="false" sslProtocol="TLS"
>                keystoreFile="conf/ssl/keystore.jks" keystorePass="changeit"/>
>
> Keystore file presents in right place, keystore password is correct.
> I create keystore this way:
> "keytool -genkey -alias tomcat -keyalg RSA -validity 365 -keystore
> conf/ssl/keystore.jks"
>
> Similar config file works pretty good for tomcat 5.5.9.
>
> What's happened to SSL?

Nothing, it works fine. Note that if you are using APR/OpenSSL, the
configuration is of course different (the APR page of the docs has the
details).

--
xxxxxxxxxxxxxxxxxxxxxxxxx
Rémy Maucherat
Developer & Consultant
JBoss Group (Europe) SàRL
xxxxxxxxxxxxxxxxxxxxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message