tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike <Tom...@canam.com>
Subject Re: File Download not working for anchor tags
Date Wed, 30 Nov 2005 22:45:43 GMT

    Hi Mark,

   I compared them and the Content-Type is not showing in 4.1.31.  In 
4.1.18 it shows as "text/plain".

   Thanks,

   Mike Gilby

At 02:47 PM 11/30/2005, you wrote:
>Assuming the content is the same, this has to be a headers issue. Try 
>installing ieHTTPHeaders (or the erquivalent for your browser) and compare 
>the differences between 4.1.18 and 4.1.31.
>
>Mark
>
>Mike wrote:
>>Hello,
>>   I'm reposting this error for hopefully more help.  I wrote before that 
>> I encountered a bug with the 4.1.31 version of Tomcat. When I use an 
>> anchor tag for a file, and I click on the link, it does not show the
>>file download message "Do you want to open or save this file?" with the open
>>and save options. Instead, it displays the file in the browser.   It use 
>>to work in Tomcat 4.1.18.  I've tried setting the "Confirm open after 
>>download" check box for file types, writing the response.contentType and 
>>response.header in the downloaded file, and I tried valves in the 
>>server.xml file for different authenticators to no avail.   I even copied 
>>the 4.1.18 Tomcat server.xml file I use to have into the Tomcat 4.1.31 
>>version, and it still doesn't work.
>>Any help would be appreciated.
>>Thanks,
>>   Mike
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>For additional commands, e-mail: users-help@tomcat.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message