tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Seak, Teng-Fong" <seak_tengf...@yahoo.com>
Subject Re: Another issue with a special character
Date Thu, 17 Nov 2005 11:09:35 GMT
    This seems to be off-topic, but let's continue

    Have you used MySQL Query Browser?  Try to insert the sign and see 
how many bytes it's using.  If it's two, it's almost certainly using 
UTF-8.  If it's one, it seems to be OK.  Then you have to figure out 
which part in your webapp is changing the character.

Information Architecture wrote:

> Hi!  I've been following the posts on special characters and have a 
> similar problem. I hope this is an appropriate list to post it to.  I 
> am not a java programmer, but support a vertical market application 
> written in java for which I do not have source and for which the 
> vendor is unhelpful at best.  The program uses a special character, 
> the copyright sign, to delimit tuples within a single field and parses 
> the field using the copyright sign when it extracts the data.  I have 
> the app working under Windows 2000 and under SuSE Linux 8.2 running on 
> a P5 system.  I am trying to move the app to SuSE SLES 9 running on a 
> dual processor opteron.  Everything works except the parts that rely 
> on this special character -- the character is inserted into the 
> database correctly, but when the field is extracted and parsed, it 
> does not work (it uses the fields within the delimiters to mark boxes 
> to check).  I have tried inserting the copyright character into a 
> field displayed as text by the app and it appears on the SLES system 
> as a ?, but on the Windows and older Linux correctly.
> The platform is mysql 4.0, tomcat 4.0 (I tried 5.0 on the new system 
> but backed down to a version I knew worked on the other system when I 
> encountered this problem), apache 1.3x (again, started with 2.0 and 
> moved back to see if the problem exists with the exact same setup).  
> Java is 1.4.1 on the old system, 1.4.2 on the new system (Sun Client 
> Hot Spot).  As far as I can see, character set is ISO 8859-1 
> throughout; it definitely is in mysql.  I have tried exporting 
> "-Dfile-encoding='ISO-8859-1'" in the catalina.sh file but to no 
> avail.  Any suggestions or ideas of where to look would be appreciated.
>
> Thanks.
>
> Becky



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message