tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <wap...@bellsouth.net>
Subject Re: Re: HTTP 404 error when mod_jk 1.2.15 connects apache 2.0.55 and tomcat 5.0.
Date Thu, 01 Jan 1970 00:00:00 GMT
netstat (or your distribution's equivalent command) should do the trick.
> 
> From: blueberry lake <blueberrylake@gmail.com>
> Date: 2005/11/30 Wed PM 03:34:58 EST
> To: Tomcat Users List <users@tomcat.apache.org>
> Subject: Re: Re: HTTP 404 error when mod_jk 1.2.15 connects apache 2.0.55 and tomcat
5.0.28 on unix
> 
> Finally, I found the problem is that port 8009 is already used by some other
> application.   I used another port, then everything works fine.
> 
> Thank you both, martin and wapace!
> 
> btw, do you know how to check if a port number has been used in UNIX?
> 
> On 11/30/05, wapace@bellsouth.net <wapace@bellsouth.net> wrote:
> >
> > And add a JkAutoAlias line to httpd.conf if you're not going to mount
> > individual directories.
> > >
> > > From: "Martin Gainty" <mgainty@hotmail.com>
> > > Date: 2005/11/30 Wed PM 02:53:22 EST
> > > To: "Tomcat Users List" <users@tomcat.apache.org>
> > > Subject: Re: HTTP 404 error when mod_jk 1.2.15 connects apache 2.0.55and tomcat
> > 5.0.28 on unix
> > >
> > > Good Afternoon Blueberry-
> > > I have some excerpts from
> > > http://tomcat.apache.org/connectors-doc/howto/apache.html
> > >
> > > I would uninstall mod_jk, clean off the TOMCAT_HOME/conf/jk folder then
> > > reinstall mod_jk 1.2.15
> > > following the doc:
> > >   If you've previously configured Apache to use mod_jserv, remove any
> > > ApJServMount directives from your httpd.conf.
> > >
> > >   If you're including tomcat-apache.conf or tomcat.conf, you'll want to
> > > remove them as well - they are specific to mod_jserv.
> > >
> > >   Remember The mod_jserv configuration directives are not compatible
> > with
> > > mod_jk !
> > >
> > > assuming your TOMCAT is properly installed and your
> > > $TOMCAT_HOME/conf/server.xml has this entry
> > > <Engine ...>
> > >     <Listener className="org.apache.jk.config.ApacheConfig"
> > > modJk="/path/to/mod_jk.so" />
> > >   </Engine>
> > > where path specified by modJk is configured correctly (usually
> > > /usr/lib/apache)
> > >
> > > be sure to turn on automatic config option in Apache configuration file
> > > called httpd.conf
> > > e.g.
> > > #To be added at the end of your httpd.conf
> > >     Include /var/tomcat3/conf/jk/mod_jk.conf-auto
> > >
> > > Then restart Tomcat and mod_jk.conf should be automatically generated
> > >
> > > be sure to read the docs for proper installation procedure
> > > HTH
> > > Martin-
> > > ----- Original Message -----
> > > From: "blueberry lake" <blueberrylake@gmail.com>
> > > To: "Tomcat Users List" <users@tomcat.apache.org>; "Martin Gainty"
> > > <mgainty@hotmail.com>
> > > Sent: Wednesday, November 30, 2005 1:19 PM
> > > Subject: Re: HTTP 404 error when mod_jk 1.2.15 connects apache 2.0.55and
> > > tomcat 5.0.28 on unix
> > >
> > >
> > > Thanks for helping.
> > > http://localhost:7888/manager/html gives me the same HTTP 404 error.
> > >
> > >
> > > On 11/30/05, Martin Gainty <mgainty@hotmail.com> wrote:
> > > >
> > > > Good Morning Blueberry
> > > > if you go to http://localhost:8081/manager/html
> > > > what happens when you Reload jsp-examples ?
> > > > Martin-
> > > > ----- Original Message -----
> > > > From: "blueberry lake" <blueberrylake@gmail.com>
> > > > To: <users@tomcat.apache.org>
> > > > Sent: Wednesday, November 30, 2005 10:39 AM
> > > > Subject: HTTP 404 error when mod_jk 1.2.15 connects apache 2.0.55 and
> > > > tomcat
> > > > 5.0.28 on unix
> > > >
> > > >
> > > > Hi all,
> > > >
> > > > I installed apache 2.0.55, tomcat 5.0.28, and mod_jk 1.2.15 on a
> > > > solaris 5.9unix machine.
> > > > Before I connected apache and tomcat, both of them work fine if I
> > start
> > > > them
> > > > up as seperate servers.
> > > > Mod_jk is complied from source code and mod_jk.so is copied to
> > > > apache/modules/
> > > >
> > > >
> > > > The connected system gives me the tomcat welcome page for URL
> > > > http://localhost:7888/
> > > > ( I changed apache to listen to port 7888. ), which seems fine. The
> > > > problem
> > > > is that when
> > > > I access the URLs like  http://localhost:7888/jsp-examples/, I got the
> > > > following error:
> > > > =====================
> > > > HTTP 404
> > > >
> > > > type Status report
> > > >
> > > > message /jsp-examples/
> > > >
> > > > description The requested resource (/jsp-examples/) is not available.
> > > >
> > > > Apache/Tomcat 5.0.28
> > > > ======================
> > > >
> > > >
> > > > For tomcat, I comment out the 8080 port (http) so that to make sure it
> > > > stops
> > > > the http service and only handles the requests
> > > > on port 8009 from apache. That's the only modification I did in
> > tomcat.
> > > >
> > > > For apache, I add workers.properties file and edit httpd.conf,
> > both  in
> > > > conf/ subdirectory.
> > > > The workers.properties is like:
> > > > ======================================
> > > > workers.tomcat_home=/usr/local/jakarta-tomcat-5.0.28
> > > > workers.java_home=/usr/j2sdk1.4.2_03
> > > > ps=/
> > > > worker.list=worker1
> > > >
> > > > worker.worker1.port=8009
> > > > worker.worker1.host=localhost
> > > > worker.worker1.type=ajp13
> > > > worker.worker1.lbfactor=50
> > > > ======================================
> > > >
> > > >
> > > >
> > > > The httpd.conf has the following modification:
> > > > =======================================
> > > > #
> > > > Listen 7888
> > > >
> > > > #
> > > > LoadModule    jk_module  modules/mod_jk.so
> > > >
> > > > #
> > > > #config of mod_jk
> > > > #
> > > > JkWorkersFile /usr/local/apache2.0.55/conf/workers.properties
> > > > JkLogFile     /usr/local/jakarta-tomcat-5.0.28/logs/mod_jk.log
> > > > JkLogLevel    info
> > > > JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
> > > > JkOptions     +ForwardKeySize +ForwardURICompat -ForwardDirectories
> > > > JkRequestLogFormat     "%w %V %T"
> > > > #
> > > > JkMount  /*  worker1
> > > > JkMount  /*/*  worker1
> > > > JkMount  /*/*/*  worker1
> > > > JkMount  /*/*/*/*  worker1
> > > > #
> > > > # End of mod_jk
> > > >
> > > >
> > > > Also the log files seem don't give me much useful info, for example,
> > the
> > > > mod_jk.log file has the following line:
> > > > [Tue Nov 29 15:33:54 2005] worker1 [localhost] 0.089465
> > > >
> > > > ANy suggestions are overwelcome!
> > > >
> > > > -b
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > > For additional commands, e-mail: users-help@tomcat.apache.org
> > > >
> > > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> >
> >
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message