tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <gbayn...@cox.net>
Subject Re: Re: can't get #include to work
Date Thu, 17 Nov 2005 17:18:39 GMT
I was on 5.5.9, I upgraded to 5.5.12 but the SSI scripts still arent' 
running.


there are no errors in any of the log files.

here's the entire contents of the calling page in case this helps:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
 <title>home</title>

</head>

<body>
This is the home page
<!--#include file="left_nav.shtml"-->
<!--#ECHO VAR="DATE_LOCAL" -->
</body>
</html>


> 
> From: "Rob Hills" <rob@netpaver.com.au>
> Date: 2005/11/17 Thu AM 10:43:43 EST
> To: Tomcat Users List <users@tomcat.apache.org>
> Subject: Re: Re: can't get #include to work
> 
> Hi,
> 
> On 17 Nov 2005 at 10:27, gbaynham@cox.net wrote:
> 
> > yes, and uncommented the lines in web.xml for both the servlet
> > definition and the mappings.
> > 
> > still don't get anything back from the SSI scripts.
> 
> Which version of Tomcat are you are using?  If 5.5.x, are you using the 
> Filter or the Servlet?  We selected the Filter and found it wasn't working 
> at first - kept getting "class not found" exceptions in the log.  Then I 
> discovered that the org.apache.catalina.ssi.SSIFilter wasn't in the 
> servlets-ssi.jar file in the version of Tomcat we were running (from 
> memory 5.5.9).  Upgraded to 5.5.12 and found it all worked perfectly.
> 
> Are you seeing anything in the logs?
> 
> > > From: "Rob Hills" <rob@netpaver.com.au>
> > > Date: 2005/11/17 Thu AM 12:03:04 EST
> > > To: <gbaynham@cox.net>
> > > Subject: Re: can't get #include to work
> > > 
> > > Hi,
> > > 
> > > On 16 Nov 2005 at 21:54, gbaynham@cox.net wrote:
> > > 
> > > > Thanks Mark,  I made the changes to the conf/web.xml.  after doing
> > > > that, however, I still can't get any of the SSI scripts to run.
> > > > 
> > > > any other help would be appreciated.
> > > 
> > > Did you remember to rename
> > > $TOMCAT_HOME/server/lib/servlets-ssi.renametojar
> > > 
> > > and then restart Tomcat?
> 
> Rob Hills 
> NetPaver Pty Ltd 
> Western Australia  
> 
> Rob Hills
> MBBS, Grad Dip Com Stud, MACS
> Senior Consultant
> Netpaver Web Solutions
> Tel:	(08) 9485 2555
> Mob:	(0412) 904 357
> Fax:	(08) 9485 2555
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message