tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhaval Patel <dhava...@yahoo.com>
Subject Help configuring mod_jk! Apache 2.0.54 + Tomcat 5.5.12 + SuSE Linux 10.0
Date Sun, 06 Nov 2005 05:05:45 GMT
Hello,

I installed SuSE 10.0 via DVD. I have added this mirror
(ftp://ftp-linux.cc.gatech.edu/pub/opensuse/distribution/SL-10.0-OSS/inst-source)
as the installation source in YaST so that I don't need DVD in future.

I installed Apache2 (ver. 2.0.54), apache2-debuginfo, apache2-devel, apache2-doc,
apache2-example-pages, apache2-prefork via YaST. I have downloaded Tomcat 5.5.12
from website. Btw. I am using J2SE 1.5.0_05.

The problem that I have is installing mod_jk with above configuration. I
downloaded the linux binary of Tomcat connector aka mod_jk from
http://www.apache.org/dist/tomcat/tomcat-connectors/jk/binaries/linux/jk-1.2.14/jakarta-tomcat-connectors-jk-1.2.14-linux-sles9-x86_64-prefork.so
. I am assuming that is the correct connector. Then I renamed it to mod_jk.so. I
tried two things:

(A) Installation procedure-1
Followed guide from
http://www.sitepoint.com/article/jsp-quick-start-guide-linux/4 with mod_jk.so in
to /usr/lib/apache2/ directory.

(B) Installation procedure-2
Followed guide from http://tomcat.apache.org/connectors-doc/howto/apache.html
with mode_jk.so in /usr/lib/apache2/ directory.

In both procedures, I get following error:
Syntax error on line 4 of /usr/local/tomcat/conf/auto/mod_jk.conf:
Cannot load /usr/lib/apache2/mod_jk.so into server: /usr/lib/apache2/mod_jk.so:
cannot open shared object file: No such file or directory

I verified that I have file on that location and file has proper access (chmod)
attributes. 

I have tried above procedure with the directory /usr/lib/apache2-prefork
directory. Same thing was repeated.

I am very new to tomcat and apache configuration esp. mod_jk. This is first time
I am installing mod_jk. I have seen it getting installed by my friends earlier
(1-2 years ago). I showed the error to them. But they dont have any clue. They
didnt do such things recently. I tried to search help on web and but could not
find proper answer.

Please help me solving this error.

Thank you very much for your help.


Regards,
Dhaval


		
__________________________________ 
Yahoo! FareChase: Search multiple travel sites in one click.
http://farechase.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message