tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duan, Nick" <ND...@mcdonaldbradley.com>
Subject RE: Certificate Revocation Lists in Tomcat 5.5
Date Tue, 29 Nov 2005 22:05:10 GMT
The official tomcat 5.5.12 was compiled and packaged with J2SE5.0, not
JDK 1.4.  You'll get an error message if you run tomcat on 1.4.

ND

-----Original Message-----
From: Mark Thomas [mailto:markt@apache.org] 
Sent: Tuesday, November 29, 2005 4:46 PM
To: Tomcat Users List
Subject: Re: Certificate Revocation Lists in Tomcat 5.5

Caldarale, Charles R wrote:
>>From: Duan, Nick [mailto:NDuan@mcdonaldbradley.com] 
>>Subject: RE: Certificate Revocation Lists in Tomcat 5.5
>>
>>Tomcat 5.5 supposed to run on JDK 1.5.  Why was it compiled with JDK
>>1.4?
> 
> 
> Because it's supposed to run on JRE 1.4 as well.  Compiling on 1.5
would
> have precluded that.

Not necessarily. But it would create complications to maintain 1.4 
compatibility where there is 1.5 specific code. The 1.5 code is 
skipped if 1.4 is used to build.

> I'm a bit suspicious of the statement that certain classes had to be
> recompiled with 1.5; I suspect there's something more subtle than that
> going on.

Nope, it is that simple. There was a discussion about this on the
dev list recently. However, I would be wary of only compiling the 
"extra" classes. To be on the safe side, I would re-build the lot with 
1.5.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message