tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luka Andrejasic" <luka.andreja...@gmail.com>
Subject Problems with Mod JK (Apache 2.052 and Tomcat 5.5.9)
Date Wed, 30 Nov 2005 00:33:05 GMT
Hello guys,

I am trying to figure this one out for weeks. Nothing seems to work and I am running out of
ideas. The problem seems to be with Mod JK, as Apache and Tomcat work without problems on
their own.

Below are all the main configuration files, as well as the error log (at the bottom) :

// System Configuration :

- OS : RedHat Linux ES 4.0 (2.6.9-22.0.1)
- Apache : 2.0.52
- Tomcat : 5.5.9
- MySQL : 4.1.12
- Mod JK : 1.2.15




// Mod JK Installation :

   tar -xzf jakarta-tomcat-connectors-jk-1.2.15-src.tar.gz
   cd jakarta-tomcat-connectors-jk-1.2.15-src
   cd jk
   cd native
   ./buildconf.sh
   ./configure --enable-EAPI --with-apxs=/usr/sbin/apxs
   make
   make install

   cp ./apache-2.0/mod_jk.so /etc/httpd/modules




// Apache Virtual Domains :

NameVirtualHost *:80


<VirtualHost *:80>
   ServerAdmin webmaster@domain.com
   DocumentRoot /var/tomcat/webapps/ROOT
   ServerName domain.com
   ServerAlias server.domain.com
   ErrorLog /home/virtual/domain.com/logs/error_log
   CustomLog /home/virtual/domain.com/logs/access_log combined

   <IfModule mod_jk.c>
       Options Indexes FollowSymLinks
       DirectoryIndex index.jsp index.html index.htm

     <Location "/META-INF/*">
       AllowOverride None
       deny from all
     </Location>

     <Location "/WEB-INF/*">
       AllowOverride None
       deny from all
     </Location>

     JkWorkersFile "/var/tomcat/conf/workers.properties"
     JkShmFile "/var/tomcat/conf/shm.file"
     JkLogFile /var/tomcat/logs/mod_jk.txt
     JkLogLevel info
     JkAutoAlias /var/tomcat/webapps/ROOT

     JkMount /backup/*  ajp13w
     JkMount /config/*  ajp13w
     JkMount /files/*  ajp13w
     JkMount /logs/*  ajp13w
     JkMount /servlet/*  ajp13w
     JkMount /sql/*  ajp13w
     JkMount /temp/*  ajp13w
     JkMount /*.jsp  ajp13w
   </IfModule>

</VirtualHost>




// File server.xml :

<Server className="org.apache.catalina.core.StandardServer"
        debug="0"
        port="8005"
        shutdown="SHUTDOWN">

  <Listener className="org.apache.catalina.mbeans.ServerLifecycleListener"
            debug="0"/>

  <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
            debug="0"/>

  <Listener className="org.apache.catalina.storeconfig.StoreConfigLifecycleListener"
            debug="0"/>

  <GlobalNamingResources>
    <Resource name="UserDatabase"
              auth="Container"
              type="org.apache.catalina.UserDatabase"
              description="User database that can be updated and saved"
              factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
              pathname="conf/tomcat-users.xml"/>
  </GlobalNamingResources>

  <Service className="org.apache.catalina.core.StandardService"
           debug="0"
           name="Catalina">

    <Connector acceptCount="128"
              className="org.apache.coyote.tomcat5.CoyoteConnector"
              connectionTimeout="20000"
              debug="0"
              enableLookups="false"
              minProcessors="32"
              maxProcessors="384"
              port="8009"
              protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"
              protocol="AJP/1.3"
              redirectPort="8443"
              useURIValidationHack="false"/>

    <Engine className="org.apache.catalina.core.StandardEngine"
            debug="0"
            defaultHost="server.domain.com"
            mapperClass="org.apache.catalina.core.StandardEngineMapper"
            name="Catalina">

      <Host className="org.apache.catalina.core.StandardHost"
            appBase="webapps"
            autoDeploy="true"
            debug="0"
            name="server.domain.com"
            unpackWARS="true"
            xmlValidation="false"
            xmlNamespaceAware="false">

        <Context charsetMapperClass="org.apache.catalina.util.CharsetMapper"
                 cookies="true"
                 crossContext="false"
                 debug="0"
                 docBase="ROOT"
                 mapperClass="org.apache.catalina.core.StandardContextMapper"
                 path=""
                 privileged="false"
                 reloadable="false"
                 swallowOutput="true"
                 useNaming="true"
                 wrapperClass="org.apache.catalina.core.StandardWrapper"/>

      </Host>

      <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
             debug="0"
             resourceName="UserDatabase"/>

    </Engine>

  </Service>

</Server>




// File workers.properties :

worker.list=ajp13w
worker.ajp13w.port=8009
worker.ajp13w.host=localhost
worker.ajp13w.type=ajp13
worker.ajp13w.cachesize=10
worker.ajp13w.cache_timeout=1200
worker.ajp13w.socket_timeout=3600




// File mod_jk.txt (Log File) :

[Tue Nov 29 18:39:57 2005] [info]  jk_handler::mod_jk.c (1993): Could not find a worker for
worker name=ajp13w




If you need anything else in order to pinpoint the problem, please tell me and I will provide
it right away. I really hope someone can help me with this.

Have a great day.

Best Regards,
Luka Andrejasic
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message