tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Missing application web.xml, using defaults only - is this a Tomcat bug?
Date Thu, 20 Oct 2005 13:44:24 GMT
> From: Rob Hills [mailto:rob@netpaver.com.au] 
> Subject: Re: Missing application web.xml, using defaults only 
> - is this a Tomcat bug?
> 
> From the my reading of the Documentation, docBase and Path are 
> mandatory attributes of the Context element for Tomcat 5.0.

Check the 5.5 doc for <Context>:
http://tomcat.apache.org/tomcat-5.5-doc/config/context.html

The path attribute is not allowed unless the <Context> element is in
server.xml, which is strongly discouraged.  (I have a vague memory of
Remy M saying that 5.5.12 disallows path, whereas previous 5.5 levels
ignored it.)  So yes, the target Tomcat level does make a difference.  I
believe that there are other configuration changes between 5.0 and 5.5
as well, notably in how resources are configured.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message