tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugo Osorio <osorio.h...@gmail.com>
Subject Re: help on a publication
Date Thu, 06 Oct 2005 22:14:56 GMT
 I have this failure inside the log, when i am trying to see the context in
the navigator..

i can solve this only fixing up the X Window ? I thought X Window had
nothing to do with this

could be another thing?

thank you


2005-10-06 19:32:32 StandardContext[/alovmap]Context initialized
58 2005-10-06 19:32:32 StandardContext[/alovmap]Exception starting filter
ogcFilter
59 java.lang.NoClassDefFoundError
60 at java.lang.Class.forName0(Native Method)
61 at java.lang.Class.forName(Class.java:141)
62 at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(
GraphicsEnvironment.java:62)
63 at java.awt.Font.initializeFont(Font.java:308)
64 at java.awt.Font.<init>(Font.java:344)
65 at org.alov.map.MapUtils.<clinit>(MapUtils.java:116)
66 at org.alov.serv.OGC_Filter.init(OGC_Filter.java:179)
67 at org.apache.catalina.core.ApplicationFilterConfig.getFilter(
ApplicationFilterConfig.java:225)
68 at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(
ApplicationFilterConfig.java:308)
69 at org.apache.catalina.core.ApplicationFilterConfig.<init>(
ApplicationFilterConfig.java:79)
70 at org.apache.catalina.core.StandardContext.filterStart(
StandardContext.java:3702)
71 at org.apache.catalina.core.StandardContext.start(StandardContext.java
:4329)
72 at org.apache.catalina.core.ContainerBase.addChildInternal(
ContainerBase.java:823)
73 at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java
:807)
74 at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:595)
75 at org.apache.catalina.core.StandardHostDeployer.install(
StandardHostDeployer.java:277)
76 at org.apache.catalina.core.StandardHost.install(StandardHost.java:832)
77 at org.apache.catalina.startup.HostConfig.deployDirectories(
HostConfig.java:701)
78 at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:432)
79 at org.apache.catalina.startup.HostConfig.start(HostConfig.java:983)
80 at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java
:349)
81 at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
LifecycleSupport.java:119)
82 at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1091)
83 at org.apache.catalina.core.StandardHost.start(StandardHost.java:789)
84 at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1083)
85 at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:478)
86 at org.apache.catalina.core.StandardService.start(StandardService.java
:480)
87 at org.apache.catalina.core.StandardServer.start(StandardServer.java
:2313)
88 at org.apache.catalina.startup.Catalina.start(Catalina.java:556)
89 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
90 at sun.reflect.NativeMethodAccessorImpl.invoke(
NativeMethodAccessorImpl.java:39)
91 at sun.reflect.DelegatingMethodAccessorImpl.invoke(
DelegatingMethodAccessorImpl.java:25)
92 at java.lang.reflect.Method.invoke(Method.java:324)
93 at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)
94 at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)


2005/10/6, Hugo Osorio <osorio.hugo@gmail.com>:
>
> here the is what i have done,
>
>
> what could be the reason because this app is not showing up
>
> thank you in advance for your help
> --------------
>
>
>
>
> by oxygene27 on 2005/10/04 16:39
>
>  Hi everybody again, please help,
>
>  Is it necessary to have the database up, for having the webapp visible in
> tomcat? it's just that i have chose as a name "mapserv" BUT i cannot see my
> publication, it is in $TOMCAT_HOME/webapps/mapserv
>
>  I have done
>
>  1. Create a dir in [TOMCAT_HOME]/webapps.
>
> 2. Unzip the distribution zip file into this folder.
>
> 3. i have created in mysql the database, running the script .sql
>
> 4. i have copied the mm.(connector JDBC).jar into the WEB-INF/lib
> directory
>
> 5. i have restarted Tomcat. and go to :
> http://myhost:8080/mapserv/index.html
>
>  and appears like nothing exist :S
>
> does not appears anything, like a wrong application
>
>  what can I do?
>
> by artem on 2005/10/04 21:37
>
>  1) Verify that the path to index database (clearinghouse) is correct.
> Open WEB-INF/mapserv-home/mapserv.xml. Check the section
>
>  <database user="root" password=""
>
> url="jdbc:mysql://localhost/alov" driver="com.mysql.jdbc.Driver"
> server="MySQL"/>
>
>  2) Verify that SQL server is up.
>
>  3) Verify that web.xml in the WEB-INF
>
>  The best way to check database is to enter into admin zone.
>
>  http://localhost:8080/map/pump
>
>  If Tomcat and our server are installed correctly you have to see the
> login screen. If connection to clearinghouse database is correct after login
> you won't see the error message.
>
> by oxygene27 on 2005/10/05 17:58
>
>  thank you, i have followed your indications, but i can't see the webapp
> yet, i dont know what's happening... all the servers are up, and the
> publication is its right place, this is the message i get:
>
>  -------------------------------------
>
> HTTP Status 404 - /alovmap/index.html
>
>  type Status report
>
>  message /alovmap/index.html
>
>  description The requested resource (/alovmap/index.html) is not
> available.
>
> Apache Tomcat/5.0.29
>
> -------------------------------------
>
>  my files are here and just like this:
>
>  $TOMCAT/webapps:
>
> drwxr-xr-x 3 www www 512 Oct 4 16:01 ROOT
>
> drwxr-xr-x 11 www www 512 Oct 5 16:11 alovmap
>
> drwxr-xr-x 4 www www 512 Nov 10 2004 balancer
>
> drwxrwxr-x 3 www www 512 Nov 10 2004 dbtest
>
> drwxr-xr-x 21 www www 512 Nov 10 2004 jsp-examples
>
> drwxr-xr-x 7 root www 512 Aug 25 16:23 lenya
>
> drwxr-xr-x 11 www www 512 Oct 5 16:10 mapserv
>
> drwxr-xr-x 4 www www 512 Nov 10 2004 servlets-examples
>
> drwxr-xr-x 12 www www 1024 Nov 10 2004 tomcat-docs
>
> drwxr-xr-x 22 www www 512 Sep 20 09:49 webdav
>
>  alovmap content:
>
> drwxr-xr-x 11 www www 512 Oct 5 16:11 .
>
> drwxr-xr-x 12 www www 512 Oct 3 18:22 ..
>
> -rw-r--r-- 1 www www 3285 Oct 3 18:27 LICENSE.txt
>
> drwxr-xr-x 2 www www 512 Oct 3 18:27 META-INF
>
> drwxr-xr-x 2 www www 512 Oct 3 18:27 Sydney
>
> drwxr-xr-x 4 www www 512 Oct 5 16:03 WEB-INF
>
> -rw-r--r-- 1 www www 266453 Oct 3 18:27 alov_applet.jar
>
> -rw-r--r-- 1 www www 435314 Oct 5 16:11 alov_servlet.jar
>
> drwxr-xr-x 2 www www 512 Oct 3 18:27 base
>
> drwxr-xr-x 2 www www 512 Oct 3 18:27 images
>
> drwxr-xr-x 2 www www 1024 Oct 3 18:27 images_wms
>
> drwxr-xr-x 2 www www 512 Oct 3 18:27 img
>
> -rw-r--r-- 1 www www 2916 Oct 3 18:27 index.html
>
> drwxr-xr-x 2 www www 512 Oct 3 18:27 layouts
>
> -rw-r--r-- 1 www www 1043 Oct 3 18:27 main3.css
>
> drwxr-xr-x 2 www www 1536 Oct 3 18:27 sample
>
> -rw-r--r-- 1 www www 150 Oct 3 18:27 top.html
>
> -rw-r--r-- 1 www www 1386 Oct 3 18:27 up_search.html
>
> -rw-r--r-- 1 www www 10270 Oct 3 18:27 wms.jsp
>
> -rw-r--r-- 1 www www 4334 Oct 3 18:27 wms.xml
>
> -rw-r--r-- 1 www www 3194 Oct 3 18:27 wms_feature.jsp
>
> -rw-r--r-- 1 www www 423 Oct 3 18:27 world.html
>
> -rw-r--r-- 1 www www 4462 Oct 3 18:27 world.xml
>
> -rw-r--r-- 1 www www 51 Oct 3 18:27 world_keymap.gfw
>
> -rw-r--r-- 1 www www 1837 Oct 3 18:27 world_keymap.gif
>
>  I WAS COPYING THE alov_servlet.jar TO THIS DIRECTORY, JUST TESTING... BUT
> after restarting the TOMCAT Server it appears the same message, like if
> nothing exist.
>
>  what could be the problem ?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message