tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rueh hänä" <r...@gmx.net>
Subject Re: AW: rueh:Problem with charsets with apache,tomcat, mysql
Date Thu, 13 Oct 2005 14:46:04 GMT
Hi.

I used de_DE, too, same effect.. I dont know, whats happening. The best
setting until now was UTF-8, because at least the html-sites were displayed
correctly. The old server uses de_DE, too, and the configs are set to
iso-8859-15. Now i set this setting once again, to be secure. But as i
expected, nothing changed. 



> Von: "Marcus Franke" <MFranke@evendi.de>
> An: "Tomcat Users List" <users@tomcat.apache.org>
> Betreff: AW: rueh:Problem with charsets with apache,tomcat, mysql
> Datum: Thu, 13 Oct 2005 15:36:52 +0200
> 
> Hi, 
> 
> have the "same" problem with a RHEL WS4.
> 
> Try using de_DE as your locale not the UTF-8 Version
> 
> > -----Ursprüngliche Nachricht-----
> > Von: "rueh hänä" [mailto:rueh@gmx.net]
> > Gesendet: Donnerstag, 13. Oktober 2005 15:32
> > An: tomcat-user@jakarta.apache.org
> > Betreff: rueh:Problem with charsets with apache,tomcat, mysql
> > 
> > HI folks
> > 
> > Soon i get desperate.
> > 
> > I have a FC4 webserver, that runs apache 2.0.54 and tomcat 5.5, mysql
> 4.1.
> > This server will be the replacement of our old FC2 webserver, that runs
> > apache 2.0.48 and tomcat 5.0.18, mysql 3.23.
> > 
> > What ive done: I took the old config from the FC2 server and adapted it
> > for
> > the new server. I also took the websites (jsp and html) on it.
> > My problem ist, that special characters as äöü (im swiss) couldnt be
> > displayed. Instead of them i get some unreadable cryptics. But i think,
> > the
> > charset settings are overall correct.
> > 
> > If i configure the default charset in httpd.conf to UTF-8, i can read
> > normal
> > html-sites, that include special characters.. withouth any problems..But
> > only html-sites.. But if i use ISO-8859-1, even html-sites are displayed
> > cryptic.
> > 
> > The system language is set to de_DE.UTF-8, as in httpd.conf and
> > tomcat5.conf
> > (LANG=de_DE.UTF-8), but i also tried it with the ISO-8859-1 charset. I
> > also
> > tried other charsets and different variations of them.. always with the
> > same
> > result. The best setting until now was UTF-8. But this only works for
> > only-html sites. The special characters still arent displayed correct on
> > jsp-sites alternatively mysql database entries.
> > 
> > Now im on this problem since about 10 hours. Nothing helped yet, no
> > similar
> > problem/solution descriptions helped. Nothing in google is appropriate
> to
> > my
> > problem.
> > 
> > Is there anything, that i forgot, didnt understand, made wrong?
> > 
> > I think, either the problem is one little thing, or more than one thing,
> > that i have to change. I hope, its the second one.
> > 
> > I really hope, you can give me am advice
> > 
> > --
> > Highspeed-Freiheit. Bei GMX supergünstig, z.B. GMX DSL_Cityflat,
> > DSL-Flatrate für nur 4,99 Euro/Monat*  http://www.gmx.net/de/go/dsl
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 

-- 
NEU: Telefon-Flatrate fürs dt. Festnetz! GMX Phone_Flat: 9,99 Euro/Mon.*
Für DSL-Nutzer. Ohne Providerwechsel! http://www.gmx.net/de/go/telefonie

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message