tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Virtual hosts and Threads
Date Wed, 28 Sep 2005 20:30:01 GMT
When starting a new thread (ie sending a message to the list about a 
new topic) please do not reply to an existing message and change the 
subject line. To many of the list archiving services and mail clients 
used by list subscribers this  makes your new message appear as part 
of the old thread. This makes it harder for other users to find 
relevant information when searching the lists.

This is known as thread hijacking and is behaviour that is frowned 
upon on this list. Frequent offenders will be removed from the list.

The correct procedure is to create a new message with a new subject. 
This will start a new thread.

Mark
tomcat-user-owner

Mahesh S Kudva wrote:
> Hi All
> 
> I have setup virtual hosts for 3 apps with virtual hosts config as 
> follows. These virtual hosts are first handled by Apache and mod_jk. My 
> apps have scheduler and automated mailing services.
> 
> <Host name="vhost.domain.com" debug="0" appBase=”deploy” 
> unpackWARs="true">
>         <Alias>www.vhost.domain.com</Alias>
>         <Logger className="org.apache.catalina.logger.FileLogger"
>             directory="${jboss.server.home.dir}/log" prefix="vhost_log1." 
> suffix=".log" timestamp="true"/>
>          <Context path="" 
> docBase="${jboss.server.home.dir}/deploy/application.war" debug="0" 
> reloadable="true"/>
>  </Host>
> 
> This config is mailing the same mail 7 time. Further I noticed that there 
> were 7 service started of the same kind. Querying the developer, he said 
> that he had coded the apps to have the mail sent once every week. The 
> mails are sent once every week but as said 7 copies of the same mail is 
> delivered.
> 
> The request for the app results in page not found if I follow the 
> following config, even thought there is no error in startup.
> 
> <Context path="application" 
> docBase="${jboss.server.home.dir}/deploy/application.war" debug="0" 
> reloadable="true"/>
> 
> 
> 
> Can you guys have any idea on this and help me troubleshoot ???
> 
> 
> Regards & Thanks
> ================
> Mahesh S Kudva
> 
> 
> -------------------------------------------------------
> Robosoft Technologies - Partners in Product Development
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message