tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mert Eren ÜSTÜNKAYA <mustunk...@cepdunyasi.com.tr>
Subject Re: where to deploy my .war and how ? help needed please!
Date Wed, 07 Sep 2005 09:56:27 GMT
Hey Yassine,

    You should deploy your codes under webapps.
I am using tomcats manager to deploy my war files i recommend it to you.

http://localhost:8080/manager/html

u can give your war file to it and deploy with out any problems..





Yassine ELassad wrote:

>good morning list,
>
>(sorry for the long mail)
>
>im running Tomcat behind an apache Server using mod_jk2 everything seems to be working
fine but im really confused about one thing
>where to deploy my .war files to???
>
>OS Suse Linux 9.1
>java version "1.4.2_03"
>Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_03-b02)
>Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode)
>
>
>tomcat is at ->  /usr/share/tomcat
>
>webapps is at /srv/www/tomcat/base/webapps
>
>my server.xml :
>======================================================
><Server port="8005" shutdown="SHUTDOWN" debug="9">
>        <Service name="Tomcat-Apache">
>                <!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 -->
>                <Connector className="org.apache.coyote.tomcat5.CoyoteConnector"
>                                                port="8009"
>                                                minProcessors="5"
>                                                maxProcessors="75"
>                                                enableLookups="true"
>                                                redirectPort="8443"
>                                                acceptCount="10"
>                                                debug="9"
>                                                connectionTimeout="20000"
>                                                useURIValidationHack="true"
>                                                protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"/>
>                <!-- While starting off, leave debugging high for help in diagn. -->
>                <!-- When done, turn it back to 0 -->
>                <Engine name="DoApache" defaultHost="do-web.de" debug="9">
>                        <Logger className="org.apache.catalina.logger.FileLogger"
>                                                prefix="doweb_fileloger."
>                                                suffix=".log"
>                                                timestamp="true"/>
>                        <!-- Access log processes all requests for this virtual host.
-->
>                        <!-- Leave pattern="combined" for the most comprehensive logging
-->
>                        <Valve className="org.apache.catalina.valves.AccessLogValve"
>                                                directory="logs"
>                                                prefix="doweb_accesslogV."
>                                                suffix=".log"
>                                                pattern="combined"
>                                                resolveHosts="false"/>
>                        <Host name="DoDemo" debug="0"
>                                        appBase="/srv/www/demo"
>                                        unpackWARs="true" autoDeploy="true">
>                                <Context path="" docBase="/srv/www/demo" debug="0"/>
>                                <Valve className="org.apache.catalina.valves.AccessLogValve"
>                                                        directory="logs"  prefix="demo_accesslogV."
>                                                        suffix=".log" pattern="combined"
resolveHosts="false"/>
>                        </Host>
>                        <Host name="doweb.de" debug="9"
>                                        appBase="/srv/www/htdocs"
>                                        unpackWARs="true" autoDeploy="true">
>                                <Context path="" docBase="/srv/www/htdocs" debug="9"/>
>                                <Valve className="org.apache.catalina.valves.AccessLogValve"
>                                                        directory="logs"  prefix="dom_access."
>                                                        suffix=".log" pattern="combined"
resolveHosts="false"/>
>                        </Host>
>                </Engine>
>        </Service>
></Server>
>========================================================
>startup log from catalina.out :
>===================================================
>Sep 7, 2005 8:05:29 AM org.apache.catalina.startup.Catalina load
>INFO: Initialization processed in 1288 ms
>Sep 7, 2005 8:05:29 AM org.apache.catalina.core.StandardService start
>INFO: Starting service Tomcat-Apache
>Sep 7, 2005 8:05:29 AM org.apache.catalina.core.StandardEngine start
>INFO: Starting Servlet Engine: Apache Tomcat/5.0.19
>Sep 7, 2005 8:05:29 AM org.apache.catalina.core.StandardHost start
>INFO: XML validation disabled
>Sep 7, 2005 8:05:29 AM org.apache.catalina.startup.ContextConfig applicationConfig
>INFO: Missing application web.xml, using defaults only StandardEngine[DOMApache].StandardHost[domdemo].StandardContext[]
>Sep 7, 2005 8:05:30 AM org.apache.catalina.core.StandardHost getDeployer
>INFO: Create Host deployer for direct deployment ( non-jmx )
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.HostConfig deployWARs
>WARNING: Exception while expanding web application archive BMIWizardDe.war
>Sep 7, 2005 8:05:30 AM org.apache.catalina.core.StandardHost start
>INFO: XML validation disabled
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.ContextConfig applicationConfig
>INFO: Missing application web.xml, using defaults only StandardEngine[DOMApache].StandardHost[do-web.de].StandardContext[]
>Sep 7, 2005 8:05:30 AM org.apache.catalina.core.StandardHost getDeployer
>INFO: Create Host deployer for direct deployment ( non-jmx )
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.HostConfig deployWARs
>WARNING: Exception while expanding web application archive BMIWizardDe.war
>Sep 7, 2005 8:05:30 AM org.apache.jk.common.ChannelSocket init
>INFO: JK2: ajp13 listening on /0.0.0.0:8009
>Sep 7, 2005 8:05:30 AM org.apache.jk.server.JkMain start
>INFO: Jk running ID=0 time=1/108  config=/usr/share/tomcat/conf/jk2.properties
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.Catalina start
>INFO: Server startup in 1254 ms
>=========================================================
>here is the log of my filelogger:
>=========================================================
>2005-09-07 08:05:30 EngineConfig: EngineConfig: Processing START
>2005-09-07 08:13:10 expand(jar:file:/srv/www/htdocs/Servlets.war!/)
>2005-09-07 08:13:10   Proposed directory name: Servlets
>2005-09-07 08:13:10   Have created expansion directory /srv/www/htdocs/Servlets
>2005-09-07 08:13:10   Have opened JAR file successfully
>2005-09-07 08:13:10   Have retrieved entries enumeration
>2005-09-07 08:13:10   Am processing entry WEB-INF/
>2005-09-07 08:13:10   Creating parent directory /srv/www/htdocs/Servlets/WEB-INF
>2005-09-07 08:13:10   Am processing entry WEB-INF/web.xml
>2005-09-07 08:13:10   Creating parent directory /srv/www/htdocs/Servlets/WEB-INF
>2005-09-07 08:13:10   Creating expanded file WEB-INF/web.xml
>=================================================================
>but when i check the directory /srv/www/htdocs/* there is no Servlets directory inside
it :s 
>im really confused and calling the Servlets from my browser doesnt help too tomcats gives
me this error message:
>
>========================================================================
>[07/Sep/2005:07:46:30 +0100] "GET /examples HTTP/1.1" 404 959 "-" "Mozilla/5.0 (Windows;
U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717  Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:32:29 +0100] "GET /examples HTTP/1.1" 404 959 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:33:09 +0100] "GET /admin HTTP/1.1" 404 950 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:34:02 +0100] "GET /index.jsp HTTP/1.1" 200 602 "-"
"Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:34:11 +0100] "GET /Servlets HTTP/1.1" 404 959 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:37:28 +0100] "GET /MartialArts HTTP/1.1" 404 968 "-"
"Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:52:22 +0100] "GET /Servlets/MartialArts  HTTP/1.1"
404 995 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:52:30 +0100] "GET /Servlets HTTP/1.1" 404 959 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>==========================================================================
>
>Notice that the 
>203.21.162.125 - - [07/Sep/2005:08:34:02 +0100] "GET /index.jsp HTTP/1.1" 200 602 "-"
"Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>was successfull but not more :s
>
>i will really apreciate any kind of help
>Thanks in Advance
>
>
>
>
>Yassine ELassad
>LHCS
>genre.con
>
>good morning list,
>
>(sorry a long mail)
> 
>im running Tomcat behind an apache Server using mod_jk2 everything seems to be working
fine but im really confused about one thing
>where to deploy my .war files to???
>OS Suse Linux 9.1
>java version "1.4.2_03"
>Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_03-b02)
>Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode)
>
>
>tomcat is at ->  /usr/share/tomcat
>
> webapps is at /srv/www/tomcat/base/webapps
>
>my server.xml :
>======================================================
><Server port="8005" shutdown="SHUTDOWN" debug="9">
>        <Service name="Tomcat-Apache">
>                <!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 -->
>                <Connector className="org.apache.coyote.tomcat5.CoyoteConnector"
>                                                port="8009"
>                                                minProcessors="5"
>                                                maxProcessors="75"
>                                                enableLookups="true"
>                                                redirectPort="8443"
>                                                acceptCount="10"
>                                                debug="9"
>                                                connectionTimeout="20000"
>                                                useURIValidationHack="true"
>                                                protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"/>
>                <!-- While starting off, leave debugging high for help in diagn. -->
>                <!-- When done, turn it back to 0 -->
>                <Engine name="DoApache" defaultHost="do-web.de" debug="9">
>                        <Logger className="org.apache.catalina.logger.FileLogger"
>                                                prefix="doweb_fileloger."
>                                                suffix=".log"
>                                                timestamp="true"/>
>                        <!-- Access log processes all requests for this virtual host.
-->
>                        <!-- Leave pattern="combined" for the most comprehensive logging
-->
>                        <Valve className="org.apache.catalina.valves.AccessLogValve"
>                                                directory="logs"
>                                                prefix="doweb_accesslogV."
>                                                suffix=".log"
>                                                pattern="combined"
>                                                resolveHosts="false"/>
>                        <Host name="DoDemo" debug="0"
>                                        appBase="/srv/www/demo"
>                                        unpackWARs="true" autoDeploy="true">
>                                <Context path="" docBase="/srv/www/demo" debug="0"/>
>                                <Valve className="org.apache.catalina.valves.AccessLogValve"
>                                                        directory="logs"  prefix="demo_accesslogV."
>                                                        suffix=".log" pattern="combined"
resolveHosts="false"/>
>                        </Host>
>                        <Host name="doweb.de" debug="9"
>                                        appBase="/srv/www/htdocs"
>                                        unpackWARs="true" autoDeploy="true">
>                                <Context path="" docBase="/srv/www/htdocs" debug="9"/>
>                                <Valve className="org.apache.catalina.valves.AccessLogValve"
>                                                        directory="logs"  prefix="dom_access."
>                                                        suffix=".log" pattern="combined"
resolveHosts="false"/>
>                        </Host>
>                </Engine>
>        </Service>
></Server>
>========================================================
>startup log from catalina.out :
>===================================================
>Sep 7, 2005 8:05:29 AM org.apache.catalina.startup.Catalina load
>INFO: Initialization processed in 1288 ms
>Sep 7, 2005 8:05:29 AM org.apache.catalina.core.StandardService start
>INFO: Starting service Tomcat-Apache
>Sep 7, 2005 8:05:29 AM org.apache.catalina.core.StandardEngine start
>INFO: Starting Servlet Engine: Apache Tomcat/5.0.19
>Sep 7, 2005 8:05:29 AM org.apache.catalina.core.StandardHost start
>INFO: XML validation disabled
>Sep 7, 2005 8:05:29 AM org.apache.catalina.startup.ContextConfig applicationConfig
>INFO: Missing application web.xml, using defaults only StandardEngine[DOMApache].StandardHost[domdemo].StandardContext[]
>Sep 7, 2005 8:05:30 AM org.apache.catalina.core.StandardHost getDeployer
>INFO: Create Host deployer for direct deployment ( non-jmx )
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.HostConfig deployWARs
>WARNING: Exception while expanding web application archive BMIWizardDe.war
>Sep 7, 2005 8:05:30 AM org.apache.catalina.core.StandardHost start
>INFO: XML validation disabled
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.ContextConfig applicationConfig
>INFO: Missing application web.xml, using defaults only StandardEngine[DOMApache].StandardHost[do-web.de].StandardContext[]
>Sep 7, 2005 8:05:30 AM org.apache.catalina.core.StandardHost getDeployer
>INFO: Create Host deployer for direct deployment ( non-jmx )
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.HostConfig deployWARs
>WARNING: Exception while expanding web application archive BMIWizardDe.war
>Sep 7, 2005 8:05:30 AM org.apache.jk.common.ChannelSocket init
>INFO: JK2: ajp13 listening on /0.0.0.0:8009
>Sep 7, 2005 8:05:30 AM org.apache.jk.server.JkMain start
>INFO: Jk running ID=0 time=1/108  config=/usr/share/tomcat/conf/jk2.properties
>Sep 7, 2005 8:05:30 AM org.apache.catalina.startup.Catalina start
>INFO: Server startup in 1254 ms
>=========================================================
>here is the log of my filelogger:
>=========================================================
>2005-09-07 08:05:30 EngineConfig: EngineConfig: Processing START
>2005-09-07 08:13:10 expand(jar:file:/srv/www/htdocs/Servlets.war!/)
>2005-09-07 08:13:10   Proposed directory name: Servlets
>2005-09-07 08:13:10   Have created expansion directory /srv/www/htdocs/Servlets
>2005-09-07 08:13:10   Have opened JAR file successfully
>2005-09-07 08:13:10   Have retrieved entries enumeration
>2005-09-07 08:13:10   Am processing entry WEB-INF/
>2005-09-07 08:13:10   Creating parent directory /srv/www/htdocs/Servlets/WEB-INF
>2005-09-07 08:13:10   Am processing entry WEB-INF/web.xml
>2005-09-07 08:13:10   Creating parent directory /srv/www/htdocs/Servlets/WEB-INF
>2005-09-07 08:13:10   Creating expanded file WEB-INF/web.xml
>=================================================================
>but when i check the directory /srv/www/htdocs/* there is no Servlets directory inside
it :s 
>im really confused and calling the Servlets from my browser doesnt help too tomcats gives
me this error message:
>
>========================================================================
>[07/Sep/2005:07:46:30 +0100] "GET /examples HTTP/1.1" 404 959 "-" "Mozilla/5.0 (Windows;
U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717  Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:32:29 +0100] "GET /examples HTTP/1.1" 404 959 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:33:09 +0100] "GET /admin HTTP/1.1" 404 950 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:34:02 +0100] "GET /index.jsp HTTP/1.1" 200 602 "-"
"Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:34:11 +0100] "GET /Servlets HTTP/1.1" 404 959 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:37:28 +0100] "GET /MartialArts HTTP/1.1" 404 968 "-"
"Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:52:22 +0100] "GET /Servlets/MartialArts  HTTP/1.1"
404 995 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>203.21.162.125 - - [07/Sep/2005:08:52:30 +0100] "GET /Servlets HTTP/1.1" 404 959 "-" "Mozilla/5.0
(Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>==========================================================================
>
>Notice that the 
>203.21.162.125 - - [07/Sep/2005:08:34:02 +0100] "GET /index.jsp HTTP/1.1" 200 602 "-"
"Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6"
>was successfull but not more :s
>
>i will really apreciate any kind of help
>Thanks in Advance
>
>
>
>
>Yassine ELassad
>LHCS
>genre.con
>
>
>
>__________________________________________________
>Verpassen Sie keine eBay-Auktion und bieten Sie bequem
>und schnell über das Telefon mit http://www.telefonbieten.de
>
>Ihre eMails auf dem Handy lesen - ohne Zeitverlust - 24h/Tag
>eMail, FAX, SMS, VoiceMail mit http://www.directbox.com
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>
>
>
>  
>



-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.344 / Virus Database: 267.10.18/91 - Release Date: 06.09.2005



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message