tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guernsey, Byron \(GE Consumer & Industrial\)" <BYRON.GUERN...@GE.COM>
Subject RE: JK 1.2.14.1 SIG BUS Error on Solaris 9
Date Fri, 02 Sep 2005 20:15:13 GMT
Some addition information- I trussed httpd -X to get this trace:

...
11438:  lwp_cond_wait(0xFEE434E8, 0xFEE434F8, 0xFEE3CD80) (sleeping...)
11438:  accept(3, 0x001EAAF4, 0x001EAB04, 1)            = 14
11438:  lwp_sema_wait(0xFE909E60)                       = 0
11438:  lwp_sema_post(0xFE909E60)                       = 0
11438:  lwp_mutex_lock(0xFEE434F8)                      = 0
11438:  lwp_mutex_wakeup(0xFEE434F8)                    = 0
11438:  lwp_sema_post(0xFE909E60)                       = 0
11438:  lwp_sema_wait(0xFE909E60)                       = 0
11438:  lwp_mutex_lock(0xFEE434F8)                      = 0
11438:  lwp_mutex_wakeup(0xFEE434F8)                    = 0
11438:  fcntl(14, F_GETFL, 0x00000000)                  = 2
11438:  fstat64(14, 0xFE909630)                         = 0
11438:  getsockopt(14, 65535, 8192, 0xFE909730, 0xFE909728, 44) = 0
11438:  fstat64(14, 0xFE909630)                         = 0
11438:  getsockopt(14, 65535, 8192, 0xFE909730, 0xFE90972C, 44) = 0
11438:  setsockopt(14, 65535, 8192, 0xFE909730, 4, 44)  = 0
11438:  fcntl(14, F_SETFL, 0x00000082)                  = 0
11438:  read(14, " G E T   / C A M C e n t".., 8000)    = 114
11438:  time()                                          = 1125691419
11438:  time()                                          = 1125691419
11438:  brk(0x001FC478)                                 = 0
11438:  brk(0x001FE478)                                 = 0
11438:  brk(0x001FE478)                                 = 0
11438:  brk(0x00200478)                                 = 0
11438:  brk(0x00200478)                                 = 0
11438:  brk(0x00202478)                                 = 0
11438:  brk(0x00202478)                                 = 0
11438:  brk(0x00204478)                                 = 0
11438:  so_socket(2, 2, 0, "", 1)                       = 15
11438:  setsockopt(15, 6, 1, 0xFE908574, 4, 1)          = 0
11438:  setsockopt(15, 65535, 128, 0xFE908578, 8, 1)    = 0
11438:  connect(15, 0x000F6CB0, 16, 1)                  = 0
11438:  fcntl(15, F_GETFL, 0x00000000)                  = 2
11438:  fstat64(15, 0xFE908290)                         = 0
11438:  getsockopt(15, 65535, 8192, 0xFE908390, 0xFE908388, 0) = 0
11438:  fstat64(15, 0xFE908290)                         = 0
11438:  getsockopt(15, 65535, 8192, 0xFE908390, 0xFE90838C, 0) = 0
11438:  setsockopt(15, 65535, 8192, 0xFE908390, 4, 0)   = 0
11438:  fcntl(15, F_SETFL, 0x00000002)                  = 0
11438:  write(15, "12 4\0AD0202\0\b H T T P".., 177)    = 177
11438:  read(15, " A B\0A4", 4)                         = 4
11438:  read(15, "04\0C8\0\0\0\003\0\n S e".., 164)     = 164
11438:  read(15, " A B\0D7", 4)                         = 4
11438:  read(15, "03\0D3\r\n\r\n\r\n < h t".., 215)     = 215
11438:  brk(0x00204478)                                 = 0
11438:  brk(0x00206478)                                 = 0
11438:  read(15, " A B\002", 4)                         = 4
11438:  read(15, "0501", 2)                             = 2
11438:  brk(0x00206478)                                 = 0
11438:  brk(0x00208478)                                 = 0
11438:  brk(0x00208478)                                 = 0
11438:  brk(0x0020A478)                                 = 0
11438:  writev(14, 0xFE907E38, 2)                       = 583
11438:      Incurred fault #5, FLTACCESS  %pc = 0xFDFC4208
11438:        siginfo: SIGBUS BUS_ADRALN addr=0xFE0E0234
11438:      Received signal #10, SIGBUS [default]
11438:        siginfo: SIGBUS BUS_ADRALN addr=0xFE0E0234
11438:          *** process killed ***
 
I hope I don't have to build a debug version of apache/mod_jk and gdb it
to find this issue. 

Help?

Byron

-----Original Message-----
From: Guernsey, Byron (GE Consumer & Industrial) 
Sent: Friday, September 02, 2005 4:00 PM
To: Tomcat Users List
Subject: JK 1.2.14.1 SIG BUS Error on Solaris 9


I tried to upgrade our JK modules from 1.2.12 to 1.2.14.1 and now every
Apache process crashes while processing a request with:

[Fri Sep 02 14:23:54 2005] [notice] child pid 11079 exit signal Bus
error (10)

For every request in the logs.

The config works fine with JK 1.2.12 (I can swap it in and things work)
and looks like:

==============================================
httpd.conf:
==============================================
JkShmSize 60
JkShmFile logs/jk1.shm
JkWorkersFile conf/workers.properties
JkMountFile conf/uriworkermap.properties
JkLogFile     logs/mod_jk_log
JkLogLevel    info
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
JkRequestLogFormat     "%w %V:%p%U%q %s %T"

<Location /jkstatus/>
    JkMount jkstatus
    Order deny,allow
    Deny from all
    Allow from 127.
</Location>

==========================================================
workers.properties:
==========================================================
ps=/
worker.list=jkstatus,CAMCentral_lb
worker.jkstatus.type=status
worker.CAMCentral_lb.type=lb
worker.CAMCentral_lb.balance_workers=ap1lnx60,ap1lnx61

worker.ap1lnx60.type=ajp13
worker.ap1lnx60.host=3.130.232.239
worker.ap1lnx60.port=15753

worker.ap1lnx61.type=ajp13
worker.ap1lnx61.host=3.130.233.24
worker.ap1lnx61.port=15753

==============================================
uriworkermap.properties
==============================================
/CAMCentral/*=CAMCentral_lb
/CAMCentral=CAMCentral_lb

Apache version:

Server version: Apache/2.0.52
Server built:   Oct 28 2004 12:24:42
Server's Module Magic Number: 20020903:9
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/worker"
 -D APR_HAS_MMAP
 -D APR_USE_FCNTL_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

What am I missing?  I built jk with configure
--with-apxs=/usr/local/apache2/bin/apxs;make

I've had no problems building/running in the past with mod_jk 1.2.12.  I
thought it must have been something in my config, but apparently not?

Byron




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message