tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "gjl" <guo-jiao...@kdc.benic.co.jp>
Subject how tomcat not run .EXE as CGI
Date Tue, 06 Sep 2005 02:24:55 GMT
Thanks very much to read my question.
I have tomcat5.0 for Win32 installed locally on
 Windows 2k, SP4. I'm trying to run a namazu.cgi.exe (a Full-Text Search
Engine. that's not Perl scripts ,but a binary file) .
the file is in Tomcat 5.0\webapps\XXX\WEB-INF\cgi ,and I set the web.xml
file as follow    <servlet>
        <servlet-name>cgi</servlet-name>

<servlet-class>org.apache.catalina.servlets.CGIServlet</servlet-class>
        <init-param>
          <param-name>clientInputTimeout</param-name>
          <param-value>100</param-value>
        </init-param>
        <init-param>
          <param-name>debug</param-name>
          <param-value>6</param-value>
        </init-param>
        <init-param>
          <param-name>cgiPathPrefix</param-name>
          <param-value>WEB-INF/cgi</param-value>
        </init-param>
         <load-on-startup>5</load-on-startup>
    </servlet>
    <servlet-mapping>
        <servlet-name>cgi</servlet-name>
        <url-pattern>/cgi-bin/*</url-pattern>
    </servlet-mapping>

 However, any reference to one of the .EXE in the
http://localhost:8080/jsp-examples/cgi-bin/namazu.cgi.exe directory results
in the browser trying to download the EXE. and I got the message "2005-09-06
10:07:25 StandardContext[/jsp-examples]cgi: runCGI (stderr):Unrecognized
character \x90 at \Tomcat
5.0\webapps\jsp-examples\WEB-INF\cgi\namazu.cgi.exe line 1." in logs.
how can I set the tomcat to run the .exe?



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message