tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Bronson" <rbronson1...@yahoo.com>
Subject Asking Again: 5.5.12 Broke my 5.5.9 Config
Date Thu, 29 Sep 2005 22:24:36 GMT
Hi all,

I asked this question a couple days ago but received no helpful 
responses. I thought I'd try one more time. If anyone has had 
experience with this, please let me know. Thanks...
--------
I've just tried to "upgrade" from TC v5.5.9 to v5.5.12 and it seems my 
(very simple) configuration is now broken.

The following configuration works beautifully under 5.5.9 -- no 
exceptions, no warnings, just utter perfection.

Here's a description of my configuration (BTW, CATALINA_HOME and 
JAvA_HOME are fine, I'm sure they're not causing the problem).

I have CATALINA_BASE set like this:
   C:\Projects\Configs\

Within this "Configs" directory I have two sub-directories: "conf" and 
"Engine_01" like this:

   C:\Projects\Configs\
       |
       +-conf\
       |  |
       |  +-server.xml
       |  +-web.xml
       |
       +-Engine01\
       |  |
       |  +-localhost\
       |  |  |
       |  |  +-ROOT.xml


Within the "conf" directory I have my "server.xml" and the default 
"web.xml" files. Here is the server.xml contents:

<Server port="10035" shutdown="SHUTDOWN" debug="0">
  <Service name="Catalina">
    <Connector port="80" />
    <Engine name="ENGINE_01" defaultHost="localhost">
      <Host name="localhost" appBase="..\Sites\Test 1"/>
    </Engine>
  </Service>
</Server>


Notice I have named the engine, "Engine_01".

As you can see, in the "Engine_01" directory I have a subdirectory, 
"localhost", which contains a context fragment file named, "ROOT.xml". 
Here is the contents of ROOT.xml:

   <Context path="" docBase=""/>


In my "server.xml" you'll notice I have my appBase property set to 
"..\Sites\Test 1". Here is the "Sites" directory structure:

   C:\Projects\Sites\
       |
       +-Test 1\
           |
           +-index.html
           +-WEB-INF\
               |
               +-web.xml
               +-classes\
               +-root\


It's all quite simple, I think. When I run under v5.5.9, this 
configuration works perfectly, as I said.

Using the EXACT SAME configuration, running under v5.5.12, I see this 
WARNING and EXCEPTION when I start TC:

WARNING: A docBase C:\Projects\Sites\Test 1\. inside the host appBase 
has been specified, and will be ignored
Sep 26, 2005 8:37:22 PM org.apache.catalina.core.StandardContext 
resourcesStart
SEVERE: Error starting static Resources
java.lang.IllegalArgumentException: Document base 
C:\Projects\Configs\..\Sites\Test 1\ROOT does not exist or is not a 
readable directory
        at 
org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:140)
        at 
org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:3777)
        at 
org.apache.catalina.core.StandardContext.start(StandardContext.java:3948)
        at 
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
        at 
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
        at 
org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
        at 
org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:603)
        at 
org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:535)
        at 
org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:470)
        at 
org.apache.catalina.startup.HostConfig.start(HostConfig.java:1118)
        at 
org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
        at 
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
        at 
org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1020)
        at 
org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
        at 
org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1012)
        at 
org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
        at 
org.apache.catalina.core.StandardService.start(StandardService.java:450)
        at 
org.apache.catalina.core.StandardServer.start(StandardServer.java:680)
        at 
org.apache.catalina.startup.Catalina.start(Catalina.java:536)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown 
Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at 
org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:275)
        at 
org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Sep 26, 2005 8:37:22 PM org.apache.catalina.core.StandardContext start
SEVERE: Error in resourceStart()
Sep 26, 2005 8:37:22 PM org.apache.catalina.core.StandardContext start
SEVERE: Error getConfigured
Sep 26, 2005 8:37:22 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [] startup failed due to previous errors
Sep 26, 2005 8:37:22 PM org.apache.catalina.core.StandardContext stop
INFO: Container 
org.apache.catalina.core.ContainerBase.[ENGINE_01].[localhost].[/] has 
not been started
Sep 26, 2005 8:37:23 PM org.apache.coyote.http11.Http11BaseProtocol 
start
INFO: Starting Coyote HTTP/1.1 on http-80
Sep 26, 2005 8:37:23 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 796 ms


So, you can see I have one WARNING and one EXCEPTION. Neither of these 
are present under v5.5.9. What's changed? Is 5.5.12 broke or was v5.5.9 
broke?

In case you are wondering, in response to the above exception I did 
indeed modify my "Sites" directory structure to include an outer "ROOT" 
directory (which was not necessary with v5.5.9):

   C:\Projects\Sites\
       |
       +-Test 1\
           |
           +-ROOT\
              |
              +-index.html
              +-WEB-INF\
                 |
                 +-web.xml
                 +-classes\
                 +-root\

Doing this eliminated the exception but I still received the WARNING 
message.

Again, does anyone know what has changed from v5.5.9 to v5.5.12 to 
cause this WARNING and SEVERE error problem???

Thanks.


--
Bob Bronson 



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message