tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeshua Lacock <>
Subject mod_jk Apache Permission Problem
Date Thu, 18 Aug 2005 21:39:07 GMT


I can't seem to make mod_jk connect successfully with Apache. Apache 
and Tomcat both works fine on their own (apache on :80 Tomcat on 
:8080), but I seem to be getting a permissions problem using mod_jk. I 
am able start Tomcat without special privileges, but when I try and 
start Apache as a non-privileged user (after starting Tomcat), I get 
the following error:

       (13)Permission denied: make_sock: could not bind to address 
       no listening sockets available, shutting down

Ideally I would like to be able to run both as a non-privileged user.

At any rate, if I either start both as root, or start Tomcat 
unprivileged and Apache with privileges, I end up getting the same 
error in the Apache 2 log:

       [Thu Aug 18 06:29:18 2005] [error] (13)Permission denied: 
apr_global_mutex_lock(jk_log_lock) failed
       [Thu Aug 18 06:29:19 2005] [notice] child pid 14821 exit signal 
Bus error (10)

It is strange because, my user account owns all of the files (I used 
chown -R to make sure). I have also tried running it as the root user 
with the same error, and changing all files to be owned by root.

I have read and followed available instructions to the best of my 

Any ideas? It seems like a simple permission problem, but I am not sure 
what might need special permissions.

Here is my Tomcat's startup information:

     Using CATALINA_BASE:   /tmp/OpenOSX/OpenWeb/jakarta-tomcat-4.1.31
     Using CATALINA_HOME:   /tmp/OpenOSX/OpenWeb/jakarta-tomcat-4.1.31
     Using JAVA_HOME:       /Library/Java/Home
     Aug 18, 2005 6:28:40 AM org.apache.coyote.http11.Http11Protocol init
     INFO: Initializing Coyote HTTP/1.1 on http-8080
     Starting service Tomcat-Standalone
     Apache Tomcat/4.1.31
     Aug 18, 2005 6:28:44 AM 
org.apache.struts.util.PropertyMessageResources <init>
     INFO: Initializing, config='org.apache.struts.util.LocalStrings', 
     Aug 18, 2005 6:28:44 AM 
org.apache.struts.util.PropertyMessageResources <init>
     INFO: Initializing, 
config='org.apache.struts.action.ActionResources', returnNull=true
     Aug 18, 2005 6:28:45 AM 
org.apache.struts.util.PropertyMessageResources <init>
     INFO: Initializing, 
config='org.apache.webapp.admin.ApplicationResources', returnNull=true
     Aug 18, 2005 6:28:53 AM org.apache.coyote.http11.Http11Protocol 
     INFO: Starting Coyote HTTP/1.1 on http-8080
     Aug 18, 2005 6:28:53 AM org.apache.jk.common.ChannelSocket init
     INFO: JK2: ajp13 listening on /
     Aug 18, 2005 6:28:53 AM org.apache.jk.server.JkMain start
     INFO: Jk running ID=0 time=1/68  
     ^CStopping service Tomcat-Standalone

Here is the pertinent mod_jk configuration from the httpd.conf:

     LoadModule jk_module modules/

     JkLogFile     /tmp/OpenOSX/OpenWeb/apache2/logs/mod_jk.log
     JkLogLevel    debug

         DocumentRoot /tmp/OpenOSX/OpenWeb//jakarta-tomcat-4.1.31/webapps
         ServerName localhost
         JkMount /*.jsp ajp13
         JkMount /examples/servlet/* ajp13

My file:

     worker.list=ajp12, ajp13

I am running Apache/2.0.54 (Unix) DAV/2 PHP/5.0.4 mod_jk/1.2.14 
mod_ssl/2.0.54 OpenSSL/0.9.7b on Mac OS X 10.3.9, built from source.

Any hints/help would be GREATLY appreciated. I am willing to compensate 
for time.


Jeshua Lacock ___________________________
Programmer/Owner		Phone:	877.240.1364		Fax:		415.462.6211

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message