tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: Deploying ROOT.war indicates missing application web.xml
Date Mon, 22 Aug 2005 10:59:03 GMT
Hi,

OK, I've found the issue :( The Ant war task appears to have packed all files that were in
the root of WEB-INF within a packed path of as web-inf (i.e lowercase) although not the classes
which are packed within an uppercase WEB-INF.

Looks like the funny theory is funny afterall.

Cheers, Allistair.

> -----Original Message-----
> From: Allistair Crossley 
> Sent: 22 August 2005 11:48
> To: Tomcat Users List
> Subject: RE: Deploying ROOT.war indicates missing application web.xml
> 
> 
> Hi,
> 
> Yes, the default ROOT.war does appear to work in the way I 
> have been trying to deploy my own ROOT.war, you're right there.
> 
> Nevertheless I will hold that there are a lot of potential 
> differences between the empty default ROOT and an 18MB 
> struts/spring/hibernate etc... real-world web application so 
> I am not convinced just yet that it's my web application 
> packaging (especially with the valid tests I have shown by 
> manual unpack).
> 
> I will see if I can pursue the reason and come back to you.
> 
> Kindest regards, Allistair.
> 
> PS: thanks for the usual insult, i'd expect no less.
> 
> > -----Original Message-----
> > From: Remy Maucherat [mailto:remy.maucherat@gmail.com]
> > Sent: 22 August 2005 11:32
> > To: Tomcat Users List
> > Subject: Re: Deploying ROOT.war indicates missing 
> application web.xml
> > 
> > 
> > On 8/22/05, Allistair Crossley <Allistair.Crossley@qas.com> wrote:
> > > Hi,
> > > 
> > > Just to reconfirm, and also to take into account what you 
> > did in your test
> > > 
> > > 0. Check server.xml for unpackWARs="true" autoDeploy="true"
> > > 1. I use Ant's war task to correctly war the web 
> > application package.
> > 
> > I used 7zip.
> > 
> > > 2. I clear Tomcat's webapps folder and restart for good measure.
> > 
> > I only deleted the "ROOT" folder.
> > 
> > > 3. I copy the war into webapps
> > > 4. Tomcat reports
> > > 
> > > INFO: Deploying web application archive ROOT.war
> > > 22-Aug-2005 11:14:02 
> > org.apache.catalina.startup.ContextConfig applicationWebConfig
> > > INFO: Missing application web.xml, using defaults only 
> > StandardEngine[Catalina].StandardHost[localhost].StandardContext[]
> > > 
> > > 5. I rename ROOT.war to ROOT.zip and open in WinZip to 
> > check file structure, in particular web.xml and to ensure 
> > that ROOT is not part of packaged paths.
> > > 6. I unzip ROOT.zip to webapps\ROOT
> > > 7. I make a request to the web application which succeeds 
> > including filters defined in the web.xml
> > > 8. Stop Tomcat
> > > 9. With WinZip, rezip the tested working ROOT folder contents
> > > 10. Delete webapps\ROOT
> > > 11. Rename ROOT.zip to ROOT.war
> > > 12. Cut ROOT.war onto Desktop.
> > > 13. Start Tomcat
> > > 14. Cut ROOT.war into webapps
> > > 15. Get same error.
> > > 
> > > INFO: Deploying web application archive ROOT.war
> > > 22-Aug-2005 11:14:02 
> > org.apache.catalina.startup.ContextConfig applicationWebConfig
> > > INFO: Missing application web.xml, using defaults only 
> > StandardEngine[Catalina].StandardHost[localhost].StandardContext[]
> > > 
> > > Could the fact that my ROOT.war is 18MB have anything to do 
> > with Tomcat's ability to examine for the web.xml??? (wild guess)
> > 
> > I know you like funny theories, but how about trying with 
> the default
> > ROOT webapp then ?
> > 
> > -- 
> > xxxxxxxxxxxxxxxxxxxxxxxxx
> > Rémy Maucherat
> > Developer & Consultant
> > JBoss Group (Europe) SàRL
> > xxxxxxxxxxxxxxxxxxxxxxxxx
> > 
> > 
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> > 
> > 
> 
> 
> <FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
> -------------------------------------------------------
> QAS Ltd.
> Registered in England: No 2582055
> Registered in Australia: No 082 851 474
> -------------------------------------------------------
> </FONT>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message