tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Cook <bc...@printtime.com>
Subject Re: SSL with Tomcat 55
Date Fri, 19 Aug 2005 14:38:29 GMT

hmmm wild guess here but are the cert file and the web app owned by the 
same user and group that executes the Tomcat thread(s)?  i.e. If Tomcat 
is run by user say tomcat, and the other persons web app is owned by 
another user, and the cert is owned by say root I could see it causing a 
problem.

It is a mistake I have made a lot and then waste a lot of time only to 
find I uploaded a file that Tomcat did not have the right permissions to 
use.


Hayes, Wes wrote:
> Good Morning,
>  
> I am the Network Admin working with a programmer trying to get TomCat
> 5.5 working with SSL.  She is trying to run a servlet via Oracle
> JDeveloper 10.1.2.  Now, on my end, I have followed the instruction for
> TomCat on how to get SSL installed and it seemed to work fine.  Got the
> test cert from Verisign and installed it and I can access it via
> Internet Explorer on https://xxx.xxx.xxx:8443 <https://xxx.xxx.xxx:8443>
> with no problem.  But when she tried to run her app she tells me this:
>  
> When I attempt to run my test stub which opens a connection to the
> servlet,  I get the following error.  I do not see this error if I run
> it through my browser.
>  
> "javax.net.ssl.SSLHandshakeException:
> sun.security.validator.ValidatorException: No trusted certificate found"
>  
> Any thoughts on this?
>  
>  
> Wesley Hayes
> Network Administrator
> AICPCU
> 720 Providence Road
> Malvern, PA 19355
> 610-644-2100 ext. 7216
> 610-651-7643 (Fax)
> hayes@cpcuiia.org
>  
>  
>  
>  
> 
> 
> ***********************************
> This e-mail and any attachments to it are confidential, privileged, and intended solely
for the named addressee(s). The unauthorized use, disclosure, or alteration of this e-mail
is strictly prohibited. If you have received this e-mail in error, please notify the sender
immediately and delete the e-mail.
> 


-- 
Brian Cook
Digital Services Analyst
Print Time Inc.
bcook@printtime.com
913.345.8900


Mime
View raw message