tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From TroyGeek <troyg...@gmail.com>
Subject Re: Problem VirtualHost WebApp Served on Two URLs
Date Mon, 22 Aug 2005 22:23:23 GMT
No, I don't believe this is the problem. I've removed the ROOT web 
application and confugured apache forwarding to tomcat using the mod_jk 
connector to forward the root webapp to 'mysite'.
 

 On 8/20/05, Peter Rossbach <pr@objektpark.de> wrote: 
> 
> You must rename your directory from mysite to ROOT.
> 
> <Context docBase="c:\sites\www.mysite.com\ROOT" path="" reloadable="true"
> source="com.ibm.wtp.web.server:mysite"/>
> 
> 
> Peter
> 
> TroyGeek schrieb:
> 
> >I have a problem with Tomcat Virtual Hosting. I have my virtual host 
> defined
> >like so in server.xml (the source thing there is from Eclipse Webtools):
> >
> ><Host name="www.mysite.com <http://www.mysite.com> <http://www.mysite.com
> >"
> >appBase="c:\sites\www.mysite.com\" unpackWARs="true" autoDeploy="true"
> >xmlValidation="false" xmlNamespaceAware="false">
> >
> ><Context docBase="c:\sites\www.mysite.com\mysite" path="" 
> reloadable="true"
> >source="com.ibm.wtp.web.server:mysite"/>
> >
> ></Host>
> >
> >When I bring up the site in the browser I can access it at:
> >http://www.mysite.com/
> >and
> >http://www.mysite.com/mysite/
> > I don't want the site to be available at http://www.mysite.com/mysite/
> > Do you know why it's serving the webapp at these two locations and not 
> just
> >the first?
> > thank you for your time,
> > Troy Campano
> >
> >
> >
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message