tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rueh hänä" <r...@gmx.net>
Subject Got trouble with virtual hosts
Date Mon, 29 Aug 2005 10:58:07 GMT
Hi there

I dont know, what term to search for.. so excuse me, if there is already a
similar problem

I'm running a Webserver on Fedora Core 4

- Apache 2.0.54
- tomcat5-5.0.30-5jpp_6fc

I want to run about 13 Websites (html and jsp) over one virtual host. So i
defined NameVirtualHost 192.168.0.170 in httpd.conf. After this entry i
added the websites. For example:

-------------------------------------------------
<VirtualHost 192.168.0.170:80>
  ServerName www.website.ch
  DocumentRoot /drbd/www/html/www.website.ch
  JKMount /*.jsp tomcat-worker1
  JKMount /*/servlet/ tomcat-worker1
  JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
  DirectoryIndex index.jsp index.html index.php index.htm index.shtml
index.cgi
  <Location "/WEB-INF/">
   AllowOverride None
   deny from all
  </Location>
  <Location "/META-INF/">
   AllowOverride None
   deny from all
  </Location>
</VirtualHost>
------------------------------------------------------------

The server.xml entry for this site is:
----------------------------------------------------------------------
<Host name="www.k-exp.ch" debug="0" appBase="/drbd/www/html/www.website.ch"
unpackWARs="true" autoDeploy="true">
        <Valve className="org.apache.catalina.valves.AccessLogValve"
               directory="/var/log/tomcat5/"
               prefix="www.kexp.ch-access."
               suffix=".log"
               resolveHosts="true"
               pattern="combined"/>
        <Logger className="org.apache.catalina.logger.FileLogger"
                directory="/var/log/tomcat5/"  prefix="www.kexp.ch_log."
suffix=".txt"
                timestamp="false"/>

        <Context path="" docBase="" debug="0"/>

        <Realm className="org.apache.catalina.realm.MemoryRealm"
               pathname="/drbd/www/html/www.k-exp.ch/WEB-INF/users.xml"/>
      </Host>
-------------------------------------------------------------

I'm replacing the actually active server with a new one. I overtook the
config-files from the active server, so they should work. The only change is
that thing with the virtual hosts. In the old config, all sites had their
own virtualhost setting (=> several virtual network interfaces). It would be
much more simple, when i only had one virtual host. 
But, if i want to access a jsp website, i get an internal server error
mesage. 
HTML-Sites work properly. 

It seems, that tomcat cant translate the hostnames defined in httpd.conf.
Can only apache do this? Or do i have to do some additional changes to my
configs?

Any idea? Thanks for help beforehand!

-- 
GMX DSL = Maximale Leistung zum minimalen Preis!
2000 MB nur 2,99, Flatrate ab 4,99 Euro/Monat: http://www.gmx.net/de/go/dsl

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message