tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anoop kumar V <anoopkum...@gmail.com>
Subject Re: Trouble Starting Tomcat
Date Sun, 31 Jul 2005 05:26:55 GMT
why dont you just go to the tomcat_home/bin dir and start using
"catalina run" command - what do u see when you try that??

Anoop

On 7/29/05, David Shapiro <dshapiro@nc.rr.com> wrote:
> Perhaps an issue with your random device or there is not enough entrophy in
> your random device.
> 
> -----Original Message-----
> From: Mark McKay [mailto:mark@kitfox.com]
> Sent: Friday, July 29, 2005 9:02 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Trouble Starting Tomcat
> 
> I'm trying to run Tomcat on a dumbed-down distor of Debian on a virtual
> linux I'm using to host my website.  I've downloaded and unzipped Tomcat
> 5.5.9 and set JAVA_HOME and CATALINA_HOME.  I start Tomcat by typing
> $CATALINA_HOME/bin/startup.sh.
> 
> Strangely, Tomcat only succesfully starts about 20% of the time.  The log
> files don't shed much light on the problem.  I've tried rebooting my server
> and waiting several minutes before requesting my first page from Tomcat, but
> I can't determine any factor that makes Tomcat more likely to successfully
> start.
> 
> Here's the logs/catalina.out generated from a failed attempt to start
> Tomcat:
> 
> Jul 29, 2005 8:42:13 PM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080 Jul 29, 2005 8:42:13 PM
> org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 14456 ms Jul 29, 2005 8:42:14 PM
> org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Jul 29, 2005 8:42:15 PM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/5.5.9 Jul 29, 2005 8:42:15 PM
> org.apache.catalina.core.StandardHost start
> INFO: XML validation disabled
> Jul 29, 2005 8:43:11 PM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> 
> 
> And this one succeeded:
> 
> Jul 29, 2005 8:46:54 PM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080 Jul 29, 2005 8:46:55 PM
> org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 3894 ms Jul 29, 2005 8:46:55 PM
> org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Jul 29, 2005 8:46:55 PM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/5.5.9 Jul 29, 2005 8:46:55 PM
> org.apache.catalina.core.StandardHost start
> INFO: XML validation disabled
> Jul 29, 2005 8:47:32 PM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080 Jul 29, 2005 8:47:33 PM
> org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009 Jul 29, 2005 8:47:40 PM
> org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/6879  config=null Jul 29, 2005 8:47:41 PM
> org.apache.catalina.storeconfig.StoreLoader load
> INFO: Find registry server-registry.xml at classpath resource Jul 29, 2005
> 8:47:43 PM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 48573 ms.
> 
> 
> Any ideas what's wrong?
> 
> Mark McKay
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


-- 
Thanks and best regards,
Anoop

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message