tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Benussi" <mark_benu...@hotmail.com>
Subject domain missing from html:rewrite html:link etc
Date Sun, 24 Jul 2005 15:17:33 GMT
I have recently moved ISPs and my sites are experiencing some strange
behaviour.

Basically on some of my sites (Not just one) and on some of the links (Not
just all) When using html:link (A struts tag library) and the other
associated tags (rewrite etc) the domain is missing.

This is also seen when using the sslext tag library which made me think that
it was a Tomcat configuration as opposed to a code specific thing (The code
has been tested in development, system test and another live environment).

I am going to give out some addresses so that people can see the problem,
but hope this won't attract unhelpful UI comments or activity as I know the
sites aren't perfect.

First customer:

http://www.cibustraining.com/view/menu.do?id=1

The links at the bottom Privacy Policy | Terms & Conditions have this
problem.

The code for them is:

<html:link page="/view/page.do?id=8" title="Privacy Policy">Privacy
Policy</html:link>
 | <html:link page="/view/page.do?id=7" title="Terms &amp; Conditions">Terms
&amp; Conditions</html:link>

Second customer

http://www.goodcookshop.com/view/menu.do?id=2

The links in the top right Why become a goodcookshop.com member? and
Register me have this problem, although the second has an extra slash after
the domain and the first one has no domain.

The code for them is:

<tr>
	<td colspan="2"><sslext:link page="/view/page.do?id=8" title="Why
become a goodcookshop.com member?">Why become a goodcookshop.com
member?</sslext:link></td>
</tr>
<tr>
	<td colspan="2"><sslext:link page="/registration/begin.do">Register
me</sslext:link></td>
</tr>

Finally I attach the server.xml for the original working configuration and
the new one which seems to be causing problems.

Original

<Server port="18005" shutdown="SHUTDOWN" debug="0">
	<Listener
className="org.apache.catalina.mbeans.ServerLifecycleListener" debug="0"/>
	<Listener
className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
debug="0"/>
	<Service name="Catalina">
		<!-- Define a non-SSL Coyote HTTP/1.1 Connector on port 8080
-->
		<Connector port="18008" enableLookups="false"
redirectPort="8443" debug="0" protocol="AJP/1.3" />
		<Engine name="Catalina" defaultHost="localhost" debug="99">
			<Logger
className="org.apache.catalina.logger.FileLogger" prefix="catalina_log."
suffix=".txt" timestamp="true" debug="99" />
			<Host name="www.goodcookshop.com" debug="0"
appBase="/web" unpackWARs="true" autoDeploy="true">
				<Alias>www.thegoodcookshop.com</Alias>
				<Alias>www.goodcookshop.co.uk</Alias>
				<Logger
className="org.apache.catalina.logger.FileLogger" prefix="goodcookshop."
suffix=".txt" timestamp="true" />
				<Context path="" docBase="" />
			</Host>
		</Engine>
		<Realm className="org.apache.catalina.realm.MemoryRealm" />
	</Service>
</Server>

New one

<?xml version="1.0"?>
<Server port="8108" shutdown="SHUTDOWN" debug="0">
      <Service name="Tomcat-Apache">
      <Connector className="org.apache.coyote.tomcat5.CoyoteConnector"
protocol="AJP/1.3" port="8208" minProcessors="5" maxProcessors="75"
acceptCount="10" debug="0"/>
      <Engine name="alberta" debug="0" defaultHost="goodcookshop.com">
      <Host name="goodcookshop.com" debug="0" unpackWARs="true"
autoDeploy="true" deployXML="true" deployOnStartup="false"
appBase="/home/tgcslimited/tomcat/webapps">
				<Alias>www.goodcookshop.com</Alias>
				<Logger
className="org.apache.catalina.logger.FileLogger"
directory="/home/tgcslimited/logs" prefix="tomcat." suffix=".txt"
timestamp="true"/>
				<Context path="/"
docBase="../../public_html" debug="0" reloadable="true"/>
      </Host>
      </Engine>
      </Service>
</Server>

Appreciate your time on this one as I didn't have any joy with google.

Cheers,

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message