tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: EL not working...
Date Thu, 07 Jul 2005 09:33:51 GMT
Hi,

I've just checked the bean taglib api and id is the page scope variable name that the cookie
value gets put into, therefore

<bean:cookie name="<%= Konstants.COOKIE_USERNAME  %>" id="username" />

<%= pageContext.getAttribute("username") %>

Really ought to be doing the job :)

> -----Original Message-----
> From: Richard Reyes [mailto:richards.list@gmail.com]
> Sent: 07 July 2005 10:24
> To: Allistair Crossley
> Cc: Tomcat Users List
> Subject: Re: EL not working...
> 
> 
> Thanks Allistair,
> 
> But it throws an error...
> 
> E:\LABDRIVE\jakarta-tomcat-5.0.28\work\Catalina\localhost\wds-
> ap\org\apache\jsp\bigler\serverpages\login_jsp.java:237:
> cannot resolve symbol
> symbol  : method setValue (java.lang.Object)
> location: class org.apache.struts.taglib.html.TextTag
>                       _jspx_th_html_text_0.setValue(
> pageContext.getAttribute("username") );
>                                           ^
> 
> On 7/7/05, Allistair Crossley <Allistair.Crossley@qas.com> wrote:
> > Yes it will be in pageContext, so
> > 
> > <%= pageContext.getAttribute("username") %>
> > 
> > > Hi Guys/Allistair,
> > >
> > > I got this code .....
> > >
> > > <bean:cookie name="<%= Konstants.COOKIE_USERNAME  %>" 
> id="username"/>
> > > .
> > > .
> > > .
> > > <td align="left"><html:text property="username"size="15"
> > > value="${username.value}" /></td>
> > >
> > > Any suggestions how to access the cookie value?
> > >
> > > Thanks
> > > Richard
> > >
> > > On 7/7/05, Allistair Crossley <Allistair.Crossley@qas.com> wrote:
> > > > EL comes with the Servlet 2.4 spec which is supported in
> > > Tomcat 5x. I believe you may be able to get EL like behaviour
> > > with the Struts-EL taglib, but you won't get it out of the
> > > box on Tomcat 4.
> > > >
> > > > Allistair.
> > > >
> > > > > -----Original Message-----
> > > > > From: Richard Reyes [mailto:richards.list@gmail.com]
> > > > > Sent: 07 July 2005 09:38
> > > > > To: Tomcat Users List
> > > > > Subject: EL not working...
> > > > >
> > > > >
> > > > > Hello Guys,
> > > > >
> > > > > EL is not working under tomcat 4. how can i make it work?
> > > > > Please help
> > > > >
> > > > > Thanks
> > > > > Richard
> > > > >
> > > > >
> > > 
> ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: 
> tomcat-user-unsubscribe@jakarta.apache.org
> > > > > For additional commands, e-mail:
> > > tomcat-user-help@jakarta.apache.org
> > > > >
> > > > >
> > > >
> > > >
> > > > <FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE>
> > > > -------------------------------------------------------
> > > > QAS Ltd.
> > > > Registered in England: No 2582055
> > > > Registered in Australia: No 082 851 474
> > > > -------------------------------------------------------
> > > > </FONT>
> > > >
> > > >
> > >
> >
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message