tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Annie Wang <lunab...@gmail.com>
Subject Re: error count for "http connector" and "localhost/ default context" seem to increment for no reason: mbean bug?
Date Fri, 01 Jul 2005 22:01:51 GMT
thanks mark!  it's working okay now w/the favicon.ico.

-annie

On 7/1/05, Mark Thomas <markt@apache.org> wrote:
> The errors are almost certainly 404s in response to the browser's
> request for favicon.ico every time you request a page. The Tomcat distro
> does not include a favicon.ico hence the 404 response.
> 
> Mark
> 
> Annie Wang wrote:
> > whenever i access any web application deployed on tomcat, i notice that error
> > count for localhost/ default[/] increments (request count also increments, not
> > sure either if request count is suppose to increment..).  http connector error
> > count also increments.  i'm checking these counter values via the tomcat
> > "manager" web application as well as through my own servlet which accesses
> > tomcat mbeans.
> >
> > even without deploying any of my own web applications (ie just after fresh
> > install of tomcat and w/o changing any default configuration), if i go to the
> > tomcat "manager" web application and continuously refresh it, it'll increment
> > error count for localhost/ default[/] and for http8080 each time i do the
> > refresh.  there doesn't seem to be any "error," so not sure why these counters
> > are incrementing..
> >
> > i've checked the logs in $CATALINA_HOME/logs, but don't see anything suspicious.
> >
> > here are the specific counters from http://<myserver>:8080/manager/jmxproxy
> > (indicated by <<<<<<<<<<<<<<<<<
):
> >
> > Name: Catalina:type=GlobalRequestProcessor,name=http8080
> > modelerType: org.apache.coyote.RequestGroupInfo
> > requestCount: 44
> > maxTime: 616
> > bytesSent: 1595769
> > bytesReceived: 0
> > processingTime: 2609
> > errorCount: 20    <<<<<<<<<<<<<<<<<
> >
> >
> > Name:
> > Catalina:j2eeType=Servlet,name=default,WebModule=//localhost/,J2EEApplication=none,J2EEServer=none
> > modelerType: org.apache.catalina.core.StandardWrapper
> > engineName: Catalina
> > eventProvider: false
> > objectName:
> > Catalina:j2eeType=Servlet,name=default,WebModule=//localhost/,J2EEApplication=none,J2EEServer=none
> > stateManageable: false
> > statisticsProvider: false
> > processingTime: 17
> > maxTime: 16
> > minTime: 0
> > requestCount: 19
> > errorCount: 19            <<<<<<<<<<<<<<<<<
> > loadTime: 0
> > classLoadTime: 0
> >
> > any ideas?
> >
> > thanks.
> > -annie
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> >
> >
> >
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message