tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jérôme Chauvin <jerome.chau...@opsomai.com>
Subject Re: binary streaming / content-type problem with mod_jk
Date Mon, 18 Jul 2005 13:20:35 GMT
Hi all !

I've developed a servlet which does a binary stream of a mpeg video file 
which is created progressively (by another servlet/software/Unix 
command/... ) and finally read and played by Quicktime.
I use Apache and Tomcat so I've installed mod_jk

All work well but... :
If I go on     http://localhost:8080/my_test/BinaryStreaming     it 
works well with QuickTime 7 and QuickTime 6 (6, 6.5, 6.5.2, ...).

I have mod_jk so I can go on      
http://localhost/my_test/BinaryStreaming       and here it still works 
well with QT7.
But QT6 seems to wait that the video file is entirely created to start 
the viewing instead of starting to play the movie as soon as there is 
data in it.
(-> like it does with QT7 and QT6 with :8080 or without :8080 and when I 
use QT7).

I think it's due to mod_jk but I've no idea to make it work


I've found that another person had a similar problem, but no answer was 
given :
http://www.junlu.com/msg/107218.html

This message was posted in 09/2004 and it seems that Apache causes 
problems with pre-defined MIME-Types.



Does someone have an answer or an idea ? :-)
Thanks in advance.

Regards,

Jérôme



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message