tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Olsson" <ja...@bananpaj.com>
Subject tomcat 5.5 and IIS 6.0 with jk1.2
Date Fri, 01 Jul 2005 11:28:02 GMT
Hi,
I'm currently trying to configure tomcat 5.5 with IIS 6.0 using the
isapi_redirector jk1.2.10 (since jk2 is deprecated).
Jk2 worked fine, but jk1.2 won't work.

This is what I've done:
-Installed Jk1.2.10 using the installer,
-Checked the windows registry to be correct,
-Configured workers.properties to:
	worker.list=ajp13w
	worker.ajp13w.type=ajp13
	worker.ajp13w.host=localhost
	worker.ajp13w.port=8009

this should be the minimal setting

-Uriworkermap.properties:
	/jsp-examples/*=ajp13w
	/manager/*=ajp13w

-Put IIS6 in IIS5 isolation mode
-Created viritual directory as given in most guides,
-Added ISAPI filter which is set to priority high and working
-Added ISAPI web service extension which is set to ALLOWED

When I try http://localhost/jsp-examples I get:
	The page cannot be displayed

And in the log file for the isapi_redirector it says (using debug mode)
"wc_get_worker_for_name::jk_worker.c (94): did not find a worker ajp 13"
"HttpExtensionProc::jk_isapi_plugin.c (974): could not get a worker for name
ajp13"

Anyone had this problem? 
Thankful for all help

// Jacob Olsson


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message