tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Anderson <benanderson...@gmail.com>
Subject java.util.zip.ZipException: invalid block type
Date Thu, 30 Jun 2005 16:43:57 GMT
Hi all,
I'm having trouble starting tomcat.  This happened after I deleted the
temp and work directories.  I recreated the temp directory because it
seemed this was a problem.  Now I'm getting this stack trace:
Apache Tomcat/4.1.31

java.util.zip.ZipException: invalid block type

	at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:140)

	at java.io.DataInputStream.readFully(DataInputStream.java:266)

	at java.util.jar.JarFile.getBytes(JarFile.java:339)

	at java.util.jar.JarFile.getManifest(JarFile.java:157)

	at org.apache.catalina.loader.WebappClassLoader.addJar(WebappClassLoader.java:654)

	at org.apache.catalina.loader.WebappLoader.setRepositories(WebappLoader.java:1020)

	at org.apache.catalina.loader.WebappLoader.start(WebappLoader.java:618)

	at org.apache.catalina.core.StandardContext.start(StandardContext.java:3486)

	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1141)

	at org.apache.catalina.core.StandardHost.start(StandardHost.java:707)

	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1141)

	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:316)

	at org.apache.catalina.core.StandardService.start(StandardService.java:450)

	at org.apache.catalina.core.StandardServer.start(StandardServer.java:2143)

	at org.apache.catalina.startup.Catalina.start(Catalina.java:463)

	at org.apache.catalina.startup.Catalina.execute(Catalina.java:350)

	at org.apache.catalina.startup.Catalina.process(Catalina.java:129)

	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

	at java.lang.reflect.Method.invoke(Method.java:324)

	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:156)

Exception during startup processing

java.lang.reflect.InvocationTargetException

	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

	at java.lang.reflect.Method.invoke(Method.java:324)

	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:156)

Caused by: java.lang.InternalError: jzentry == 0,
 jzfile = 118335776,
 total = 2482,
 name = tools\tomcat\4.1.31\temp\jar_cache53708.tmp,
 i = 34,
 message = invalid LOC header (bad signature)

	at java.util.zip.ZipFile$2.nextElement(ZipFile.java:320)

	at java.util.jar.JarFile$1.nextElement(JarFile.java:211)

	at org.apache.catalina.startup.ContextConfig.tldScanJar(ContextConfig.java:850)

	at org.apache.catalina.startup.ContextConfig.tldScan(ContextConfig.java:809)

	at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:587)

	at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:181)

	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)

	at org.apache.catalina.core.StandardContext.start(StandardContext.java:3523)

	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1141)

	at org.apache.catalina.core.StandardHost.start(StandardHost.java:707)

	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1141)

	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:316)

	at org.apache.catalina.core.StandardService.start(StandardService.java:450)

	at org.apache.catalina.core.StandardServer.start(StandardServer.java:2143)

	at org.apache.catalina.startup.Catalina.start(Catalina.java:463)

	at org.apache.catalina.startup.Catalina.execute(Catalina.java:350)

	at org.apache.catalina.startup.Catalina.process(Catalina.java:129)

	... 5 more


So, first impulse is to say that there's a bad jar file in there
somewhere.  Only this isn't the case.  I've deleted jars and it just
fails on the next one.  I'm guessing this has something to do with me
deleting the temp and work directories.  I did this because we're
checking tomcat into our svn repository.  Any ideas what's going on
here?
Thanks,
Ben

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message