tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Convy \(Contractor\)" <Ke...@iceboxllc.com>
Subject Problem posting a large request that requires authentication and is forwarded through the NSAPI redirector
Date Fri, 03 Jun 2005 19:38:08 GMT
For the following configuration:
 
Sun ONE / iPlanet 6.0sp5 
NSAPI redirector from jakarta-tomcat-connectors-1.2.8
Tomcat 5.5 (embedded in JBoss 4.0.2)
 
All of the requests that get forwarded over the redirector require
authentication. The configuration works fine if the request body is less
than ~150k or if I include the http authorization header in the initial
request. However, if  I attempt to post a request over 150k and don't
include the authorization header (which forces the authentication
challenge) I get an "Error writing to server" on the client.
 
If I look at the nsapi redirector log I see that Tomcat does not read
the entire request before issuing the challenge, though I don't know if
it should:
 
[Fri Jun 03 10:21:24 2005] [715:0] [debug] service::jk_lb_worker.c
(482): service worker=worker3 jvm_route=worker3 rc=1
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_marshal_into_msgb::jk_ajp_common.c (551): ajp marshaling done
[Fri Jun 03 10:21:24 2005] [715:0] [debug] ajp_service::jk_ajp_common.c
(1594): processing with 3 retries
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_connection_tcp_send_message::jk_ajp_common.c (883): sending to ajp13
pos=4 len=254 max=8192 
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_send_request::jk_ajp_common.c (1199): request body to send 180594 -
request body to resend 0
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_connection_tcp_send_message::jk_ajp_common.c (883): sending to ajp13
pos=4 len=8192 max=8192 
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_connection_tcp_get_message::jk_ajp_common.c (1007): received from
ajp13 pos=0 len=126 max=8192 
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_unmarshal_response::jk_ajp_common.c (606): status = 401
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_unmarshal_response::jk_ajp_common.c (613): Number of headers is = 3
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_unmarshal_response::jk_ajp_common.c (669): Header[0]
[WWW-Authenticate] = [Basic realm="Salton"]
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_unmarshal_response::jk_ajp_common.c (669): Header[1] [Content-Type]
= [text/html;charset=utf-8]
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_unmarshal_response::jk_ajp_common.c (669): Header[2]
[Content-Length] = [952]
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_connection_tcp_get_message::jk_ajp_common.c (1007): received from
ajp13 pos=0 len=956 max=8192 
[Fri Jun 03 10:21:24 2005] [715:0] [debug]
ajp_connection_tcp_get_message::jk_ajp_common.c (1007): received from
ajp13 pos=0 len=2 max=8192 
[Fri Jun 03 10:21:24 2005] [715:0] [debug] ajp_done::jk_ajp_common.c
(1942): recycling connection cache slot=0

If I post the request directly to Tomcat (not over AJP through the
redirector) then it also works fine.
 
Has anyone run into this issue?
 
Any information would be appreciated.
 
Thanks,
  
Kevin Convy
Icebox LLC

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message