tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anoop kumar V <anoopkum...@gmail.com>
Subject java.lang.NoClassDefFoundError: sun/tools/javac/Main
Date Wed, 15 Jun 2005 16:30:24 GMT
I am using Tomcat 4.1.30 standalone and am repeatedly facing this issue of

java.lang.NoClassDefFoundError: sun/tools/javac/Main

whenever I try to serve up a jsp from a specific folder within webapps.

I know that this is a classpath issue - but i have checked my
JAVA_HOME and it is pointing correctly to my jdk.
I mean I have lots of other applications working fine in the webapps
folder so JAVA_HOME has never been the issue. (the other jsp files
from other folders in webapps are served just fine)

Also from a google search someone pointed out that TOMCAT_HOME or
CATALINA_HOME needs to be set. I tried setting this too in startup.bat
and catalina.bat (even setclasspath.bat) but in vain.

I know that tomcat 4.1.30 completely ignores the system classpath - so
I have not tried to change that.

Another point is that I compiled using JDK1.5_01 but the tomcat4.1.30
I am using points to jdk1.4.2.

On Tomcat5.5 (pointing to jdk1.5) this worked like a charm - I just
dropped the war in webapps and the jsp was displayed.

Can anybody give me some pointers as to how I can automatically fix
this in 4.1.30?

Thanks in advance,
Anoop

-- 
Thanks and best regards,
Anoop

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message