tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: getRemoteUser() always returns null
Date Wed, 22 Jun 2005 08:22:55 GMT
Hi,

Try setting tomcatAuthentication="false" on the connector, or jk2.properties file

Cheers, Allistair.

> -----Original Message-----
> From: Scott Heitkamp [mailto:scott_heitkamp@yahoo.com]
> Sent: 21 June 2005 21:40
> To: tomcat-user@jakarta.apache.org
> Subject: getRemoteUser() always returns null
> 
> 
> I'm currently using tomcat with the apache connector.  I use 
> apache to authenicate the user and then allow them to access 
> certain servlets in tomcat.  My problem is that when I call 
> getRemoteUser in the servlet, it always returns null even 
> though I was authenticated through apache.  I'm assuming that 
> it's because the request isn't sending the Authorization 
> Header to tomcat.  How do I get it?
> 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 
> 


<FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
-------------------------------------------------------
QAS Ltd.
Registered in England: No 2582055
Registered in Australia: No 082 851 474
-------------------------------------------------------
</FONT>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message