tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Angelov, Rossen" <Rossen.Ange...@SourceMedia.com>
Subject RE: servlet request time out ?!
Date Fri, 03 Jun 2005 16:07:54 GMT
I tried adding it to my .../WEB-INF/web.xml 
<web-app>
....
  <session-config>
    <session-timeout>45</session-timeout>
  </session-config>

  ...
</web-app>

but I started getting errors when tomcat is deploying the context:

Jun 3, 2005 11:51:20 AM org.apache.commons.digester.Digester error
SEVERE: Parse Error at line 28 column 11: The content of element type
"web-app" must match
"(icon?,display-name?,description?,distributable?,context-param*,filter*,fil
ter-mapping*,listener*,servlet*,servlet-mapping*,session-config?,mime-mappin
g*,welcome-file-list?,error-page*,taglib*,resource-env-ref*,resource-ref*,se
curity-constraint*,login-config?,security-role*,env-entry*,ejb-ref*,ejb-loca
l-ref*)".
org.xml.sax.SAXParseException: The content of element type "web-app" must
match
"(icon?,display-name?,description?,distributable?,context-param*,filter*,fil
ter-mapping*,listener*,servlet*,servlet-mapping*,session-config?,mime-mappin
g*,welcome-file-list?,error-page*,taglib*,resource-env-ref*,resource-ref*,se
curity-constraint*,login-config?,security-role*,env-entry*,ejb-ref*,ejb-loca
l-ref*)".

It looks like an XML error, but I don't see where is the problem.
Removing the above 3 lines gets rid of the errors

Ross
-----Original Message-----
From: J. Alejandro Zepeda Cort├ęs [mailto:janux@chile.com]
Sent: Thursday, June 02, 2005 11:10 AM
To: Tomcat Users List
Subject: Re: servlet request time out ?!


Maybe the setting in your web.xml is not enough for your request?

    <session-config>
      <session-timeout>45</session-timeout>    <!-- 30 minutes by default-->
    </session-config>

----- Original Message ----- 
From: "Angelov, Rossen" <Rossen.Angelov@SourceMedia.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Thursday, June 02, 2005 11:34 AM
Subject: RE: servlet request time out ?!


> I would like to bring that issue up again as I haven't resolved it yet and
> haven't found what's causing it.
>
> Any help and ideas are welcome!
>
> Thanks,
> Ross
>
> -----Original Message-----
> From: Angelov, Rossen
> Sent: Thursday, May 26, 2005 1:33 PM
> To: 'Tomcat Users List'
> Subject: servlet request time out ?!
>
>
> Hi,
> Does anybody know about a time out on a servlet request with Tomcat 5?
>
> The problem is that I have a request that takes about 30 minutes but the
> browser keeps waiting for the response forever. I tried different browsers
> but it's the same behavior.
>
> I put debug statements in the doPost method and it's finishing correctly.
> The last debug statement is printed out but the browser is still waiting
for
> the response.
>
> Ross
>
> "This communication is intended solely for the addressee and is
> confidential and not for third party unauthorized distribution."
>
>
>
> "This communication is intended solely for the addressee and is
> confidential and not for third party unauthorized distribution."
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

"This communication is intended solely for the addressee and is
confidential and not for third party unauthorized distribution."


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message