tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Kutzinski <>
Subject Re: tomcat does not like cmdline args of wget?
Date Tue, 14 Jun 2005 14:16:43 GMT
Holger Klawitter wrote:
> Christoph Kutzinski wrote:
>>wget --http-user=theUser --http-passwd=thePass http://theHost/someURL
>>wget http://theUser:thePass@theHost/someURL
>>with BASIC auth
>>Or are you really literally writing
>>wget http://theUser:thePass@theHost/someURL
> of course not :-)

Why, not? It is always a good idea to start testing the simple things ;)

> There was no shell escaping involved (username and password both matched
> "[a-zA-Z0-9]*" and escaping would affect both access patterns the same way,
> wouldn't it?)

Not necessarily. If the password would contain %20 for example, this 
would probably be interpreted as a space in
wget http://theUser:thePass@theHost/someURL,
but as %20 in
wget --http-user=theUser --http-passwd=thePass http://theHost/someURL

I have no more ideas. Currently sounds like a wget problem to me, too.
But I cannot imagine that wget should have such a big error.
(I just tried it here without problems)
Have you tried the same with other browsers?

You could google for problems with wget authentication. Maybe others 
have found similar problems.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message