tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Kriger <andy.kri...@gmail.com>
Subject help needed with UTFDataFormatException
Date Thu, 23 Jun 2005 19:08:30 GMT
Hello. I have a Tomcat 5.5.8 based web application running an Axis
1.2.0 driven web service. When I run a certain chunk of code doing
XSLT transformations, the code fails with "There was an error while
transforming document - java.io.UTFDataFormatException: Invalid byte 1
of 1-byte UTF-8 sequence."

I can run this code outside of Tomcat without any problem (using
command-line JUnit tests). However, if I run the code from a JSP page
or using my web service, it fails with that error.

Xerces and Xalan are definitely the same version (System.out with
their respective Version objects shows the same info). I am attaching
the XSLT file in question in case anyone can see something I can't.

Has anyone seen this problem? I'm not finding much useful information
searching the archives (of Tomcat, Axis or googling the
web/newsgroups).

thx
andy

Mime
View raw message