tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Faine, Mark" <Mark.R.Fa...@msfc.nasa.gov>
Subject BadPaddingException revisited
Date Wed, 04 May 2005 14:27:07 GMT
 
 
Is a keystore required to use PKCS12 ssl certs with Tomcat 5?  I'm trying
(once again) to convert a cert issued for Apache (OpenSSL) to a pkcs12 for
Tomcat but I keep getting the following error:
 
 Protocol handler start failed: java.io.IOException: failed to decrypt safe
contents entry: javax.crypto.BadPaddingException: Given final block not
properly padded...
 
I've  had this problem before and was able to overcome it though I don't
know how.  I don't know what I did to get it working last time and I'm
hoping I can once and for all determine the cause of this error so that I
will not have to go through this again.
 
I've been trying the following openssl command to convert the cert
 
openssl pkcs12 -export -in mycert.cer -inkey mykey.key -out cert.p12 -name
tomcat -CAfile entrust_ssl_ca.cer -caname root -chain
 
I'd appreciate any help I could get on this issue.
 
Thanks,
-Mark
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message