tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: POST not working
Date Thu, 05 May 2005 12:34:03 GMT
well, i'm not entirely sure, but i remember having this problem last year when using jCIFs
for authentication and IE6. 

we solved it by ensuring we instructed tomcat not to attempt authentication, and allowing
therefore IIS to pass thru the remote user login

this is done on the AJP <Connector> element with tomcatAuthentication="false". however,
i think the admin tool uses basic authentication. It could be this mixed mode that you have
causing issues. I am not totally sure, but see this ...

http://www.websina.com/bugzero/kb/browser-ie.html

> -----Original Message-----
> From: Christian Dechery [mailto:christian@ability.com.br]
> Sent: 05 May 2005 13:25
> To: Tomcat Users List
> Subject: Re: POST not working
> 
> 
> As a matter of fact I am. Is that the cause?
> 
> Ah, I forgot to mention, we have the exact same setup (a 
> mirror-development server) here, but running on Tomcat 5 and it works 
> fine. Should we upgrade?
> 
> Allistair Crossley wrote:
> 
> >are you running IE6 and NTLM-authenticated applications?
> >
> >  
> >
> >>-----Original Message-----
> >>From: Christian Dechery [mailto:christian@ability.com.br]
> >>Sent: 05 May 2005 13:16
> >>To: Tomcat Users List
> >>Subject: Re: POST not working
> >>
> >>
> >>It's a regular JSP page with nothing to it. This application 
> >>(SCA) works 
> >>perfectly, I've been using it for two years on several projects.. 
> >>Suddenly all the POSTs on the server stopped working BUT the main 
> >>application (the huge intranet thing).
> >>
> >>It's not any error in MY application (or any application, for that 
> >>matter), proof of that, is that even the /admin application 
> >>that comes 
> >>with tomcat is not working. I can't login cuz it uses POST 
> to process 
> >>login and password, and I'm 110% sure using the correct 
> user/password 
> >>but it always gives me "Invalid login/password", for the 
> >>obvious reason 
> >>it isn't getting ANY user/password from the POSTed form.
> >>
> >>It's something with the server, but I don't have a clue. :(
> >>
> >>Allistair Crossley wrote:
> >>
> >>    
> >>
> >>>what are you posting to? what does your html <form> tag look 
> >>>      
> >>>
> >>like, have you specified multipart?
> >>    
> >>
> >>> 
> >>>
> >>>      
> >>>
> >>>>-----Original Message-----
> >>>>From: Christian Dechery [mailto:christian@ability.com.br]
> >>>>Sent: 05 May 2005 13:02
> >>>>To: Tomcat Users List
> >>>>Subject: Re: POST not working
> >>>>
> >>>>
> >>>>I don't get any response, no errors presented, I just 
> realised that 
> >>>>nothing is being POSTed.
> >>>>Only GET works.
> >>>>
> >>>>Mark Thomas wrote:
> >>>>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>What response do you get when you try to POST?
> >>>>>
> >>>>>Mark
> >>>>>
> >>>>>Christian Dechery wrote:
> >>>>>
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>>>Hi everyone, hope u can help me solve this one. It's at 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>least weird.
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>I have a 4.1.3 installed on a FreeBSD machine running a 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>huge intranet 
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>corporate system. It runs smoothly and very fast, but for 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>some very 
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>weird reason, that webapp is the only one on the server 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>wich allows 
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>POST.
> >>>>>>
> >>>>>>Even the /admin tool won't allow posts, therefore I can't 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>login to it.
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>I have another webapp (a little one, for access control), 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>installed. 
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>It is the simplest webapp possible, only a few JSPs, but 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>POST doesn't 
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>work on it, only GET.
> >>>>>>
> >>>>>>I've searched through server.xml looking for something 
> that could 
> >>>>>>explain this, but found nothing. I have even created a 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>><Context> for 
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>SCA exactly as the one I have for the main application.
> >>>>>>
> >>>>>>Any clues?
> >>>>>>
> >>>>>>Thanks in advance,
> >>>>>>Christian from Rio, Brazil
> >>>>>>
> >>>>>>
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>------------------------------------------------------------
> >>>>        
> >>>>
> >>---------
> >>    
> >>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>To unsubscribe, e-mail: 
> tomcat-user-unsubscribe@jakarta.apache.org
> >>>>>>For additional commands, e-mail: 
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>tomcat-user-help@jakarta.apache.org
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>------------------------------------------------------------
> >>>>        
> >>>>
> >>---------
> >>    
> >>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>To unsubscribe, e-mail: 
> tomcat-user-unsubscribe@jakarta.apache.org
> >>>>>For additional commands, e-mail: 
> >>>>>          
> >>>>>
> >>tomcat-user-help@jakarta.apache.org
> >>    
> >>
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>------------------------------------------------------------
> >>>>        
> >>>>
> >>---------
> >>    
> >>
> >>>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> >>>>For additional commands, e-mail: 
> tomcat-user-help@jakarta.apache.org
> >>>>
> >>>>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>><FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
> >>>-------------------------------------------------------
> >>>QAS Ltd.
> >>>Developers of QuickAddress Software
> >>><a href="http://www.qas.com">www.qas.com</a>
> >>>Registered in England: No 2582055
> >>>Registered in Australia: No 082 851 474
> >>>-------------------------------------------------------
> >>></FONT>
> >>>
> >>>
> >>>-----------------------------------------------------------
> ----------
> >>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> >>>For additional commands, e-mail: 
> tomcat-user-help@jakarta.apache.org
> >>>
> >>>
> >>> 
> >>>
> >>>      
> >>>
> >>-- 
> >>**------------------------------------------------------------
> >>------------------** 
> >>
> >>	*Christian Dechery
> >>Analista / Desenvolvedor
> >>A B I L I T Y *Soluções Interativas*
> >>*+55 21 38526657*
> >>*www.ability.com.br* <http://www.ability.com.br>*
> >>
> >>
> >>------------------------------------------------------------
> ---------
> >>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> >>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> >>
> >>
> >>    
> >>
> >
> >
> ><FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
> >-------------------------------------------------------
> >QAS Ltd.
> >Developers of QuickAddress Software
> ><a href="http://www.qas.com">www.qas.com</a>
> >Registered in England: No 2582055
> >Registered in Australia: No 082 851 474
> >-------------------------------------------------------
> ></FONT>
> >
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> >For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> >
> >
> >  
> >
> 
> -- 
> **------------------------------------------------------------
> ------------------** 
> 
> 	*Christian Dechery
> Analista / Desenvolvedor
> A B I L I T Y *Soluções Interativas*
> *+55 21 38526657*
> *www.ability.com.br* <http://www.ability.com.br>*
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


<FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
-------------------------------------------------------
QAS Ltd.
Developers of QuickAddress Software
<a href="http://www.qas.com">www.qas.com</a>
Registered in England: No 2582055
Registered in Australia: No 082 851 474
-------------------------------------------------------
</FONT>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message