tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From andre.laga...@education.gouv.fr
Subject Re: Tomcat j2sdk and image
Date Mon, 02 May 2005 17:45:53 GMT
Yes I have a graphics environnement.
I put these command lines in startup.sh
DISPLAY=10.10.10.1:0.0
export DISPLAY

The generation of GIF image works but it make a long time on Solaris 8.

Trond G. Ziarkowski a écrit :
> Hi,
> 
> do you have a graphics environment when running under Solaris?
> If not then that would be my guess to a reason why it's not working, 
> since you have a graphics environment when running under W2K.
> 
> Try adding -Djava.awt.headless=true to your commandline when starting 
> tomcat. If this doesn't do the trick, you need the graphics environment 
> to generate your images.
> 
> 
> Trond
> 
> andre.lagadec@education.gouv.fr wrote:
> 
>> Hi,
>>
>> The program java use :
>> java.awt.Frame;
>> java.awt.Graphics;
>> java.awt.Image;
>>
>> and Acme.JPM.encoders.GifEncoders who encode image in Gif.
>>
>> N.B. : the application works fine on W2K with Tomcat-4.0.4 using 
>> jdk-1.3.1, and Tomcat-4.1.30 and Tomcat-5.0.28 with jdk-1.4.2
>>
>> Dale, Matt a écrit :
>>
>>> I'd be surprised if anyone could with the scant information you have 
>>> provided. You haven't even mentioned the image library that you are 
>>> using.
>>>
>>> I would suggest that you get a profiler or debugger in order to work 
>>> out what your code is doing at the time that it is generating the 
>>> image and which methods are taking all the time.
>>>
>>> Ta
>>> Matt
>>>
>>> -----Original Message-----
>>> From: andre.lagadec@education.gouv.fr
>>> [mailto:andre.lagadec@education.gouv.fr]
>>> Sent: 02 May 2005 16:33
>>> To: tomcat-user@jakarta.apache.org
>>> Subject: Tomcat j2sdk and image
>>>
>>>
>>> Hi,
>>>
>>> I have a java application who generate image.
>>> On Sun Solaris 8, It works fine with Tomcat-4.0.4 and jdk-1.3.1
>>> It was the same with Tomcat-4.1.18 and jdk-1.4.1
>>>
>>> But when I use Tomcat-4.1.30 with jdk-1.4.2 or Tomcat-5.0.28 with
>>> jdk-1.4.1 or jdk-1.4.2, the image make a long time to be generating.
>>>
>>> What is the problem ?
>>> Can somebody help me ?
>>>
>>> AL
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>>
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>
>>
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message