tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Serlet Jean-Claude <jean-claude.ser...@insee.fr>
Subject RE: Undeploying webapp on windows
Date Tue, 10 May 2005 12:28:43 GMT
Hello

Have you tried to use the command undeploy of the manager ?
Like this 
http://yourhost:yourportnumber/manager/undeploy?path=(context_path) 
Take care : this command after stopping the application will delete the
directory where your application was deployed and remove the entry of the
<Context> from your server.xml of CATALINA_HOME/conf


Jean-Claude

-----Message d'origine-----
De : Joakim Ahlén [mailto:joakima@geosition.com]
Envoyé : mardi 10 mai 2005 09:20
À : Tomcat Users List
Objet : Undeploying webapp on windows


Hi,

I guess this question has come up a thousand times on this list, but i 
still have no workaround for it so i need to get a tip or two from you guys.

We're using Tomcat 5.5.9 on Windows 2003 Server, and we cannot 
hot-deploy webapps. The cause is one of our jar-files in WEB-INF being 
locked, so the webapp cannot be undeployed. (The directory 
webapps/<webapp>/ cannot be deleted).

Now, i've scanned the net a lot about this problem and have tried lots 
and lots of stuff.

- Stopping the webapp before trying to remove the 
webapps/<webapp>/-directory does NOT work.
- Using reloadable="true", antiJARLocking="true" 
antiResourceLocking="true" in the context.xml for each webapp does NOT work.

We have about 75 (almost identical) webapps or so running on our server. 
With the software "Process Explorer" from sysinternals 
(http://www.sysinternals.com/files/procexpnt.zip), i can see all open 
files in the system. On any given time, "tomcat5.exe" has one jar-file 
in each of about 3-5 webapps open with a file handle. These are never 
closed, but open for as long as tomcat lives (or at least, for a very 
long time. Hours or days.)

Now, i know what is said about this problem. "It's an OS problem, not a 
tomcat issue". I can't understand that though, since:

- Hot deploy worked perfectly under windows with tomcat 4.1.X. What has 
changed since then?
- Tomcat evidently has several file handles open to these jar-files 
which it doesn't close. Isn't the problem this, that tomcat doesn't 
close the file handles to its opened jar-files?

I can close these file handles manually from within process explorer, 
but then tomcat goes berserk and nothing works.

Is there anything i'm missing here?
Isn't there any way whatsoever to be able to use hot deploy under 
windows today?
Why doesn't antiJARLocking and antiResourceLocking work at all, i 
thought these should adress this particular problem?

I'm attaching a screenshot of the open files from within process explorer.

Hope you can help me!

Regards

Joakim



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message