tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan August <...@internection.com>
Subject Re: no host matches server name localhost
Date Wed, 27 Apr 2005 20:50:51 GMT

I think I was just missing a Context.

Thanks for the help, Rod!!

	-Jon



On Apr 27, 2005, at 4:24 PM, Jonathan August wrote:

>
> Hmm, I have pretty much what you have.  Here's the whole server.xml:
>
>
> <Server port="8005" shutdown="SHUTDOWN" debug="0">
>
>   <Listener  
> className="org.apache.catalina.mbeans.ServerLifecycleListener"
>             debug="0"/>
>   <Listener  
> className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
>             debug="0"/>
>
>   <!-- Global JNDI resources -->
>   <GlobalNamingResources>
>     <Resource name="UserDatabase" auth="Container"
>               type="org.apache.catalina.UserDatabase"
>        description="User database that can be updated and saved">
>     </Resource>
>     <ResourceParams name="UserDatabase">
>       <parameter>
>         <name>factory</name>
>          
> <value>org.apache.catalina.users.MemoryUserDatabaseFactory</value>
>       </parameter>
>       <parameter>
>         <name>pathname</name>
>         <value>conf/tomcat-users.xml</value>
>       </parameter>
>     </ResourceParams>
>   </GlobalNamingResources>
>
>   <!-- Define the Tomcat Stand-Alone Service -->
>   <Service name="Catalina">
>
>     <!-- Define a non-SSL Coyote HTTP/1.1 Connector on port 8080 -->
>     <Connector port="8080"
>                maxThreads="150" minSpareThreads="25"  
> maxSpareThreads="75"
>                enableLookups="false" redirectPort="8443"  
> acceptCount="100"
>                debug="0" connectionTimeout="20000"
>                disableUploadTimeout="true" />
>
>     <!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 -->
>     <Connector port="8009"
>                enableLookups="false" redirectPort="8443" debug="0"
>                protocol="AJP/1.3" />
>
>     <!-- Define the top level container in our container hierarchy -->
>     <Engine name="Catalina" defaultHost="localhost" debug="0">
>
>       <!-- Global logger unless overridden at lower levels -->
>       <Logger className="org.apache.catalina.logger.FileLogger"
>               prefix="catalina_log." suffix=".txt"
>               timestamp="true"/>
>
>       <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
>                  debug="0" resourceName="UserDatabase"/>
>
>       <!-- Define the default virtual host
>            Note: XML Schema validation will not work with Xerces 2.2.
>        -->
>       <Host name="localhost" debug="0" appBase="webapps"
>        unpackWARs="true" autoDeploy="true"
>        xmlValidation="false" xmlNamespaceAware="false">
>
>         <Logger className="org.apache.catalina.logger.FileLogger"
>                  directory="logs"  prefix="localhost_log."  
> suffix=".txt"
>             timestamp="true"/>
>
>       </Host>
>
>     </Engine>
>
>   </Service>
>
> </Server>
>
>
>
>
>
> On Apr 27, 2005, at 4:08 PM, Rod Fitzsimmons Frey wrote:
>
>> I should have looked at your message more closely.
>>
>> The error is probably with your default host.  Look in your  
>> {tomcat-home}/conf/server.xml file.  Look for something like
>>
>>      <Host name="localhost" appBase="webapps"
>>       unpackWARs="true" autoDeploy="true"
>>       xmlValidation="false" xmlNamespaceAware="false">
>>
>> Post your server.xml file if you can't work it out.
>>
>> Rod
>>
>> Jonathan August wrote:
>>
>>> This is my /etc/hosts:
>>>
>>>
>>> [jon ~]$ cat /etc/hosts
>>> # Do not remove the following line, or various programs
>>> # that require network functionality will fail.
>>> 127.0.0.1       localhost.localdomain   localhost
>>>
>>>
>>>
>>> On Apr 27, 2005, at 3:52 PM, Rod Fitzsimmons Frey wrote:
>>>
>>>> What do you have in your /etc/hosts file?
>>>>
>>>> Jonathan August wrote:
>>>>
>>>>>
>>>>> I installed Tomcat 5.0.30 using yum on Fedora Core 3.  When I try  
>>>>> to connect to http://localhost:8080/, I get:
>>>>>
>>>>> Alert!: HTTP/1.1 400 No Host matches server name localhost
>>>>>
>>>>> I'm sure I'm missing something simple, but I'm pretty new at this,  
>>>>> so I'm not sure what to check.
>>>>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
----
Jon August
Internection
1-866-345-HOST



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message