tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Durfee, Bernard" <>
Subject RE: java.library.path - DLL - Domino
Date Wed, 06 Apr 2005 22:37:24 GMT
Problem solved, I restarted Eclipse, waved my hands a couple times and
presto, the DLL is found no problem. The wonders of Java on Windows.
Although it would be great if someone could explain how with a DLL in a
path in the "java.library.path" could not be found.

Bernard Durfee

-----Original Message-----
From: Durfee, Bernard 
Sent: Wednesday, April 06, 2005 4:34 PM
To: Tomcat Users List
Subject: java.library.path - DLL - Domino

I am trying to use the native library for connecting to Domino from a
servlet. I was under the impression that the DLL needed to be in the
path specified by the java.library.path system property. However, this
does not seem to work.

I got to the point where even brute force did not work...

System.setProperty("java.library.path", "D:\\Lotus\\Domino");"Using java.library.path: " +

...from the logger...

Using java.library.path: D:\Lotus\Domino

...then the line...


...fails with the following exception...

java.lang.UnsatisfiedLinkError: no nlsxbe in java.library.path
	at java.lang.ClassLoader.loadLibrary(Unknown Source)
	at java.lang.Runtime.loadLibrary0(Unknown Source)
	at java.lang.System.loadLibrary(Unknown Source)

...and indeed I do have a DLL file D:\Lotus\Domino\nlsxbe.dll. This is
on a Windows 2000 machine. Any ideas?

Bernard Durfee

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message