tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Durfee, Bernard" <Bernard.Dur...@suny.edu>
Subject RE: java.library.path - DLL - Domino
Date Wed, 06 Apr 2005 21:18:27 GMT
Yes, I started by making sure that the DLL was in the Windows system
path. I also tried running the DLL as you suggested and it did indeed
find the DLL and complain about the bad entry point. I believe that
Tomcat supplies a special class loader to each web application. I also
believe that the class loader is expected to find libraries and such. So
the question is, where do I put my DLL so that the web application class
loader can find it? Apparently the answer is not "java.library.path",
unless there is a bug in Tomcat preventing it from properly parsing the
path.

Bernard Durfee


-----Original Message-----
From: Jay Burgess [mailto:java@vtgroup.com] 
Sent: Wednesday, April 06, 2005 5:01 PM
To: tomcat-user@jakarta.apache.org
Subject: RE: java.library.path - DLL - Domino


Have you tried putting it into your system path via the PATH environment
variable?  (If you're running Tomcat as a service, you'll need to reboot
to have it take effect I think.)

If it's there, what happens if you run "rundll32 nlsxbe
SomeDummyEntryPoint"? 
it should find the DLL, but complain about the invalid entry point.

Jay
Vertical Technology Group
http://www.vtgroup.com/
 

-----Original Message-----
From: Durfee, Bernard [mailto:Bernard.Durfee@suny.edu] 
Sent: Wednesday, April 06, 2005 3:34 PM
To: Tomcat Users List
Subject: java.library.path - DLL - Domino

I am trying to use the native library for connecting to Domino from a
servlet. I was under the impression that the DLL needed to be in the
path specified by the java.library.path system property. However, this
does not seem to work.

I got to the point where even brute force did not work...

System.setProperty("java.library.path", "D:\\Lotus\\Domino");
m_logger.info("Using java.library.path: " +
System.getProperty("java.library.path"));

...from the logger...

Using java.library.path: D:\Lotus\Domino

...then the line...

System.loadLibrary("nlsxbe");

...fails with the following exception...

java.lang.UnsatisfiedLinkError: no nlsxbe in java.library.path
	at java.lang.ClassLoader.loadLibrary(Unknown Source)
	at java.lang.Runtime.loadLibrary0(Unknown Source)
	at java.lang.System.loadLibrary(Unknown Source)

...and indeed I do have a DLL file D:\Lotus\Domino\nlsxbe.dll. This is
on a Windows 2000 machine. Any ideas?

Bernard Durfee

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org






---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message