tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anto Paul <antop...@gmail.com>
Subject Re: Debugging tomcat startup
Date Sat, 02 Apr 2005 07:16:11 GMT
On Apr 2, 2005 1:27 AM, Sasha Borodin <sasha@whoissasha.com> wrote:
> I'd like to solicit suggestions for debugging Tomcat startup - specifically
> various class initializations.
> 
> I've written a custom Realm implementation; in it, I use some data access
> classes which use iBatis; these classes work great when used in a web
> application (all jars residing in the apps WEB-INF/lib); but I'm getting
> errors when these classes are initialized from jars in the server/lib
> directory at startup.
> 
> If you have suggestions for how to debug the startup, especially from an IDE
> like Idea, please post.  Also, if there are guidelines for where to place
> certain types of jars (common vs. server), please post a link.  Right now
> I've got my jdbc jars in common/lib, and my custom Realm and data access
> classes (including ibatis related jars) in server/lib.
> 
> Thanks for your help,
> 
> -Sasha Borodin
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 

Read the classloader docs.
http://jakarta.apache.org/tomcat/tomcat-5.5-doc/class-loader-howto.html

What is the motive to place jars in server/lib. These jars are not
visible to applications.

-- 
Anto Paul
Benchmark Softech
www.benchmarksoft.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message