tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <remy.mauche...@gmail.com>
Subject Re: Tomcat 5.5.x and Java 1.5
Date Thu, 07 Apr 2005 09:21:12 GMT
On Apr 7, 2005 11:15 AM, Steiner, Stephan <Stephan.Steiner@nextiraone.ch> wrote:
> Hi
> 
> I'm trying to compile a couple of jsp pages that use Java 1.5 syntax. I
> followed the Jasper how-to and replaced the jdt jar with the latest ant.jar
> (taken from the Ant 1.6.2 distribution). After a restart of Tomcat, Tomcat
> now uses the JDK compiler (I see different error message for my Java 1.5
> code). However, the default is to write code compatible with JDK 1.4.
> 
> So I added the following lines to my web.xml config file (in the jsp servlet
> section) and restarted Tomcat again:
> 
>         <init-param>
>             <param-name>compilerSourceVM</param>
>             <param-value>1.5</param>
>         </init-param>
>         <init-param>
>             <param-name>compilerTargetVM</param>
>             <param-value>1.5</param>
>         </init-param>
> 
> After a restart, trying to access any page yields a 404 error, with no
> entries in the logfiles. Setting the version number to 1.4 instead yields
> the same behavior. Removing those two init-params again and everything is
> back to normal, but I still can't use Java 1.5 features. Is there anything
> I'm missing to run Java 1.5 code on Tomcat 5.5.x?

I updated JDT in Tomcat CVS to 3.1M6, as well as handling of those two
properties (which may or may not fix Ant, as I didn't test it), so you
can try building a new Jasper from CVS.

-- 
xxxxxxxxxxxxxxxxxxxxxxxxx
Rémy Maucherat
Developer & Consultant
JBoss Group (Europe) SàRL
xxxxxxxxxxxxxxxxxxxxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message