tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Leone <midnightj...@cox.net>
Subject Re: Error 400 no such host.
Date Sun, 24 Apr 2005 05:26:26 GMT
FWIW, I tried this on my Windows XP system, and it worked. I copied the 
webapps folder with one of its app folders to the system root directory, 
set appbase="c:\webapps", and it worked.

One observation that may shed some light on your problem. When I first 
tried it, I only copied my axis webapp folder. When I went to 
http://localhost:8080/ I got a blank page (not a "Host not found" 
error). But I could navigate to http://localhost:8080/axis and see the 
axis web app. Then I copied the "Root" folder from the original webapps 
directory to the new location, and I got the usual Tomcat startup page 
when I went to http://localhost:8080/. Did you copy the Root folder over 
when you tried it?

jesper wrote:

>My system is tomcat 5.5.7 on linux mandrake 10.1 with sun java 1.5
>my server.xml
>/webpps is the original webapps dir, moved to /, to test the absolute path in 
>appBase.. I get 400 no such host
>Has anybody, here made it work with an absoulte path, on linux? How?
>
><?xml version="1.0"?>
>
>
><Server port="8005" shutdown="SHUTDOWN">
>  <Service name="Catalina">
>    <Connector port="8009" enableLookups="false" redirectPort="8443" 
>protocol="AJP/1.3"/>
>
>    <Engine name="Catalina" defaultHost="localhost">
> <Host appBase="/webapps" name="localhost" unpackWARs="true" 
>autoDeploy="false">
>
></Engine>  
></Service>
>
></Server>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>
>  
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message