tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bengt Lassen <bengt.las...@email.de>
Subject Problems with timestamps in logfiles
Date Fri, 01 Apr 2005 13:40:31 GMT
Hello

I´m having rather strange things (for me at last :->) going on.
This is the basic environment

tomcat    4.1.31
java        1.4.2 IBM build  for Power5
os            SLES9.0 for Power

We have configured special logfiles for our webapps using the <logger>

<Logger
   className="org.apache.catalina.logger.FileLogger"
   debug="9"
   directory="/var/log/tomcat"
   prefix="vapplive1_mvpzv."
   suffix=".log"
   timestamp="true"
   verbosity="9" />

This works fine, most of the time. Sometimes it happens, that the
timestamp gets gets out of sync with the real world
It´s creating entries like this
   vi vapplive1_mvpzv.1970-01-01.log
   ....
   1970-01-01 01:00:00 StandardContext[/mvpzv]:   Trying exact match
   1970-01-01 01:00:00 StandardContext[/mvpzv]:   Trying prefix match
   1970-01-01 01:00:00 StandardContext[/mvpzv]:   Trying extension match
   ...
This happens once in a while. I usally restart the tomcat and then it
works well for a while.
It seems to me that the tomcat is somehow getting the wrong time.
The time on the server is syncronized using ntp so the systemtime is
right.

Has anybody seen somethng like this ?

Furthermore I´m looking for a way to get timestamps in the
catalina.out logfile. Does anyone know where to configure this ?

TIA

Bengt


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message