tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Mehrle" <mich...@datasaur.com>
Subject Re: Tomcat taking 125 seconds to launch
Date Sun, 03 Apr 2005 21:04:27 GMT
Hi Mark:

Okay, the machine is a P4, 1GB RAM (512MB assigned to tomcat), and besides 
Tomcat 5.5.9, there's Apache running and mysql. Apache is not in use much. I 
have the apache logging set to WARN, so the slowdown is not due to excessive 
logging.

The site is running an image gallery and there are probably around 100 jps 
for the gallery and image pages. I am not sure if adding jsps does affect 
the startup time.

The configuration is a modified version of appfuse 1.5 (struts and 
hibernate) - so this should give you a good idea of how it is structured. 
FYI: on my development machine here at home Tomcat starts in 28 seconds - 
identical project and configuration.

Any help would be greatly appreciated - if you need any configuration files, 
just ask and I'll email them to you.

Michael


----- Original Message ----- 
From: "Mark" <elihusmails@gmail.com>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Sunday, April 03, 2005 1:39 PM
Subject: Re: Tomcat taking 125 seconds to launch


> gonna need more information.   hardware, config files..etc.
>
> On Apr 2, 2005 6:42 PM, Michael Mehrle <michael@datasaur.com> wrote:
>> I just installed tomcat 5.5.9 on Fedora FC3 and it's suddenly taking a 
>> long
>> amount of time to launch - 125 seconds to be exact!
>>
>> INFO: Starting Coyote HTTP/1.1 on http-8080
>> Apr 2, 2005 6:39:00 PM org.apache.jk.common.ChannelSocket init
>> INFO: JK: ajp13 listening on /0.0.0.0:8009
>> Apr 2, 2005 6:39:00 PM org.apache.jk.server.JkMain start
>> INFO: Jk running ID=0 time=0/364  config=null
>> Apr 2, 2005 6:39:00 PM org.apache.catalina.storeconfig.StoreLoader load
>> INFO: Find registry server-registry.xml at classpath resource
>> Apr 2, 2005 6:39:00 PM org.apache.catalina.startup.Catalina start
>> INFO: Server startup in 125430 ms
>>
>> I didn't have this problem before - does anyone experience the same 
>> delay?
>> It's also looking a bit more sluggish... Any input would be greatly
>> appreciated.
>>
>> Michael
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message